• nylon
  • NEWBIE
  • 465 Points
  • Member since 2011

  • Chatter
    Feed
  • 18
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
    Questions
  • 83
    Replies

I have a standard contracts object and a standard accounts object in my org. A custom field checkbox in my contracts object will, when true, send an email template notification. This rule works flawlessly, except in one particular case. It is a complete mystery. The one exception is contracts associated with an account I have named "Richard Coren." (No quotes. Just Richard Coren.) The notification absolutely will not work with that named account, nor will it work if I clone the account, or if I create another account also named, "Richard Coren." If I change one letter in the account name -- for example, if I change the account name to Richard Scoren --  then the rule works again. I have explored every possibility and shared this conundrum with colleagues more experienced than myself, and yet none of has been able to solve this mystery. 

 

Guesses anyone?

  • January 05, 2012
  • Like
  • 0

I'm using the Developer edition of Salesforce, following this tutorial:
http://www.salesforce.com/us/developer/docs/fundamentals/index.htm


I've got to the stage where I have to create users in certain profiles.

 

I have created a profile called Recruiter, and its User License is shown as Salesforce.

 

Now, I go to create a new user, I select Salesforce Platform for the User License, but then the only profile available in the drop down is Standard Platform User. In fact, no matter which User License I select (Force.com, Chatter Free or Salesforce Platform), I still can't see the Recruiter profile in the Profile dropdown.

 

Further, I have 24 profiles created in total - some were created automatically for me when I signed up, and others are from various experiments - but the vast majority of these never appear for selection on the New User page. The only ones I ever see are (depending on which User License I select) are:

 

  • Force.com - Free User
  • Chatter Free User
  • Chatter - Moderator
  • Standard Platform User

What am I doing wrong?

Hi,

 

 

I have 2 custom objects, Customer and Call Log. There's a lookup from Call Log to Customer. So, i have a related list 'Call Logs' on Customer detail page.

 

I have overriden the 'New' button on the related list, so when now the button is pressed, it redirects to the actual new record creation page, and also auto populates some values, including the lookup field to Customer with the name of the customer.

 

The code behind the button is:

 

/a07/e?CF00NA0000006AZ2f={!Customer__c.Name}&retURL=%2F{!Customer__c.Id}&RecordType=012A000000177i9&ent=01IA0000001TSOU

 CF00NA0000006AZ2f = the lookup field id (retreived from firebug)

 

Scenario:

 

Now, it works absolutely fine. But the thing is, since i am populating the lookup field with the name, if there are 2 customers by the name of "ABC", then both appear in edit page lookup field dropdown. The user is given an option to select one, and he, if sees the same name can select the incorrect one also.

 

 

Can anyone help me with this please?

 

Thanks,

Sumit

Hello,

 

I am currently in the process of trying to data remedaite URL's within our SFDC environment.  Using the Force.com IDE I thought I would be able to search within WebLinks or Components to find and replace the links I need to change.

I note there are links on my Home Page Components > Custom Links which do not appear within the "weblinks" or "components" in my Force.Com IDE.  Do you know where these would be stored therefore within the IDE?  I want to make sure I do not miss any links in my environment which i need changing.  Should Custom Links not exist within WebLinks?

 

Thanks in advance.

 

Hi

I created a custom object with a data type number.

 

When I input data into this field it adds comas when you review.

I can't use the text type because I only want numbers.

 

Thanks, Just getting going on things, after 23 years of basic top down programming this is fun.

  • September 14, 2011
  • Like
  • 0

hi, im new to salesforce and i was wondering what was the difference between __c and __r when refering to a custom object. Also can u give me examples. thanks

Good Evening, All,

I know that I am missing something simple here, but I don't know just what that simple is :-)

I am trying to create a validation rule that won't allow specific parts to be ordered when a specific drop down box field is chosen on a part order.  Part Orders are cases, while the individual parts are custom objects.

Here is the rule I have in place:

AND
(BEGINS( $RecordType.Name , "Part/Supply Order"),
ISPICKVAL(Order_Type__c, "Parts"), OR(
(Part_1__c = "09-5000 (Lids, Case (1000)" ),
(Part_1__c = "09-1100 (Straws, 300 Count Package)" ),
(Part_1__c = "09-5200 (Spoons, 1000/Case)" ),
(Part_1__c = "09-1406 (Test Kit, Sanitizer)" ),
(Part_1__c = "09-1410-A (Sanitizer Kit, Standard)" )))

 

The goal is to have an error displayed when a Party/Supply Order case record type is saved, the value "Parts" is selected in the drop down field "Order Type" and then one of the listed parts is put in the Part 1 field.  The "Part 1" field is a lookup field for the parts custom object.

Any thoughts?

It seemed so easy and straighforward, but it apparently isn't!

Thanks!

Mike


  • September 01, 2011
  • Like
  • 0

Is there any way to set the display order for the related-list in the standard pagelayout.

I found that the display of the related-list is disordered.

I need to set them in order.

Thanks

  • August 30, 2011
  • Like
  • 0

I have a fomula field which returns percent. It displays correctlly in the object page layout.But the percent character was missing when the record show in the relate list in it's father object's page.

Is there any way to configure to the percent field showing? Or it's just the bug of salesforce?

Thanks

  • August 30, 2011
  • Like
  • 0

Hi,

 

I have created two custom object called as coverage and Analyst. When we open some record of Analyst custom object a wall is coming where we can post messages related to that record  but when we open record of coverage custom object no wall is coming. Is there any chatter setting presence for custom object sbecause in one object chatter is visible where we can post messages but for other it's not. Can anyone explain what is happening.

 

Thanks,

Rajiv

  • August 29, 2011
  • Like
  • 0

Trying to create rule criteria within a WF to assign a task to the Opportunity Owner only IF the Opp Owner role does not contain the letters "CSR".  Where I'm hitting a roadblock is how to insert criteria based on the Opp Owner.  I have created the following for my WF rule but it will only fire based on the User's role.

 

Rule Name: Update Stage because Close Date has passed.

Description: Opportunity Owner to be assigned task to update the stage when Today's Date is greater than the Close Date.  Opportunity Owner role must not contain "CSR".



Rule Criteria:

NOT (CONTAINS($UserRole.Name, "CSR")) 
&& (CloseDate < TODAY()) 
&& (ISPICKVAL(StageName, "Solution Acceptance/Sample(s)") 
|| ISPICKVAL(StageName, "Quote") 
|| ISPICKVAL(StageName, "Build Value Proposition"))

I thought that this would work if I could add another layer to the rule criteria that included Opportunity Owner = User, but again I'm back to my roadblock of not being able to base criteria on the Opp Owner (unless I'm overlooking that option).

 

Any ideas on how to side step this roadblock?  Thank you in advance for reading and for your thoughts.

 

Alexis

Hi All,

We had a lookup relationship between to object and we were copying the owner of the parent to child when ever a new child record got inserted. But if the owner of the parent is an inactive user then the child record cannot be inserted because we were getting the exception "Insert failed. Operation performed with Inactive User".

 

So, then we changed the lookup in to master-detail and now we are able to create a child record for a parent whose owner is inactive. So, I am curious to know what value would be assigned to that child record. But I could neither query the ownerId field for that child object nor find the ownerid field in eclipse. 

 

Do anyone know what Salesforce does with the ownerid field of a child record in a master-detail relationship? And is there a way to query that field?

 

Thanks,

Sorna

  • August 22, 2011
  • Like
  • 0

Is it possible to overwrite the salesforce.com logo with my companies logo?

 

Has anyone done this in the service cloud?

 

Thanks.

V

Hi,

 

I need to take a date field and update another date field to be the original date + 1 year.  And also take the day from the original date and make it the last day of the month.

 

Can I do this by workflow? Or do I need to write some APEX for it?

 

Thanks.

Hi all, 

 

I am in need to inactive a user. While trying to inactive, it showing the following message.

 

User's page layout and language used by Executive Opportunity Alerts.

 

This user's page layout and language settings are applied to all Executive Opportunity Alerts. This user must be an active user with the 'View All Data' permission. Before changing the user settings or profile, select a different user for Executive Opportunity Alerts. 

 

I have removed all the reports and dashboards assosiate with this user, and tried to change the record type for his profile. Even also i cant able to inactive. Kindly help me out. Thanks in advance.

 

 

  • August 16, 2011
  • Like
  • 0

Hi,

 

I have an issue with seeing/editing another user's data.

 

1. I have 'edit quota' enabled in my profile

2. I am able to 'Manage Users'

3. The other users's profile shows that I am his manager

4. The other user has 'edit quota' enabled

5. In the forecasting hierarchy I show as being "above" the other user

6. Both of us have forecasting enabled.

7. Our site is configured for 'customizable forecasting'

 

I am able to see and modify my quota (from the user profile screen) but am unable

to see the 'Quotas' area in his profile.

 

Can someone tell me what is missing in the configuration?

 

         Thx,

 

                  aqueller

Hi,

 

    How many sandbox environments are available by default for Unlimited and Enterprise Edition? Can we buy additional Sandbox environments for Enterprise and Unlimited Editions. 

 

Thanks

 

           

Dear Folks,

 

I have created a formula field in a report builder and placed that field as a column in my report.It is running fine and when I exported that report in to an excel, I could not see the formula field column values.But I want those values also to be exported in to an Excel.

 

Kindly suggest with a solution ASAP.

 

Thanks in advance,

Deepa.

  • August 08, 2011
  • Like
  • 0

I have a standard contracts object and a standard accounts object in my org. A custom field checkbox in my contracts object will, when true, send an email template notification. This rule works flawlessly, except in one particular case. It is a complete mystery. The one exception is contracts associated with an account I have named "Richard Coren." (No quotes. Just Richard Coren.) The notification absolutely will not work with that named account, nor will it work if I clone the account, or if I create another account also named, "Richard Coren." If I change one letter in the account name -- for example, if I change the account name to Richard Scoren --  then the rule works again. I have explored every possibility and shared this conundrum with colleagues more experienced than myself, and yet none of has been able to solve this mystery. 

 

Guesses anyone?

  • January 05, 2012
  • Like
  • 0

Guys, 

 

Sorry for the oh-so-simple question here, and forgive if ive posted in the wrong forum.

 

I changed the Calendar view to show details within the calandar, and now of course, when looking at the teams activities for the coming week, the canedar is spread over a huge page.

 

I need to change the setting back to simple view, so that details are only showed on mouse-over, but for the life of me cannot remember where that check-box is for that setting.

 

Anyone can point me in the right direction?

 

Please??

I'm using the Developer edition of Salesforce, following this tutorial:
http://www.salesforce.com/us/developer/docs/fundamentals/index.htm


I've got to the stage where I have to create users in certain profiles.

 

I have created a profile called Recruiter, and its User License is shown as Salesforce.

 

Now, I go to create a new user, I select Salesforce Platform for the User License, but then the only profile available in the drop down is Standard Platform User. In fact, no matter which User License I select (Force.com, Chatter Free or Salesforce Platform), I still can't see the Recruiter profile in the Profile dropdown.

 

Further, I have 24 profiles created in total - some were created automatically for me when I signed up, and others are from various experiments - but the vast majority of these never appear for selection on the New User page. The only ones I ever see are (depending on which User License I select) are:

 

  • Force.com - Free User
  • Chatter Free User
  • Chatter - Moderator
  • Standard Platform User

What am I doing wrong?

Hi All,

 

I have a custom object called CMCs__c which has multiple page layouts. I have a custom button on a related object (Service_Agreement__c)  to create a new record. Is there a way in the parameters of the custom button to define which page layout is used? Or is there another way to acheive this?

 

Thanks in advance for your help.

Hi,

 

I have a Production environment on Enterprise Edition and earlier had 10 Salesforce licenses.

 

We created a Sandbox and had 10 licenses propagated to Sandbox too.

 

Now, we purchased more licenses and have total 30 Salesforce licenses in Production.

 

But in Sandbox we still have 10 licenses. How can I have the 20 more licenses in the Sandbox org too? I know of the Full Sandbox Refresh solution but then right now development is in full peak and I dont want any refresh to happen now.

 

Can anyone advise how can I have the same number of licenses in Sandbox environment too?

 

 

Thanks,

 

Vimal

Hi

 

    How Stage & Probability Setup in Opportunities has been done . Can we customize it , if yes then how . Suppose i want to create my Stages & accordingly Probability.

 

Thanks

I'd like to sort an activity report on accounts by the number of completed activities on each account.  I was told by support that since the number of activities is a summary and not a field, I couldn't sort by that.  I believe this means I need a formula field on the account that summarizes the number of activities completed on that account and then I can sort using that field.  Can anyone assist with that formula or another solution to my problem? 

Hello,

 

I ran into storage space issues on my Full Sandbox. On inspecting Storage Usage, I found that Task records were taking up  the bulk of storage. There are around 100 K Task records. Also when I run  the query  - Select count() from Task - it returns zero records. So my assumption is that all of these tasks are archived.

 

 I need to delete these archived Tasks, but I 'm running into road blocks. These are the approaches I have tried -

 

  1. Mass Delete option from the UI. This will delete 250 records in one shot. This is going to be very cumbersome considering I have 100k records
  2. Wrote a Batch Apex class to delete tasks. But am unable to retrieve archived Tasks. The query  - 'Select Id from Task  limit 50000 all rows'  - always returns zero records. I read that queryAll( ) is the way to go to retrieve archived records, but is there a way to use queryAll in a Batch Apex class?
  3. DataLoader - this seems to be the fastest way to delete records, in combination with the Bulk API. But the same problem of retrieving archived tasks exists here too.  There are zero rows exported I export Task using this tool. I read somewhere that archived records can't be exported using DataLoader ?

What are the alternatives that I have ? Please advise.

 

Regards,

Tarams

  

  • October 11, 2011
  • Like
  • 0

I have introduced a workflow rule that sends out an email based on time-based workflow rule. It starts sending out email when it still meets the workflow criteria 21 days prior to a datetime field.

 

My problem is that there are some records created before the introduction of the workflow rule (hence the time triggers have not been set)  and is halfway thru the 21 day period that were updated thus firing off the workflow rule and creating some time triggers in the past. Thus sending a ton of the same emails an hour or so after updating.

 

How do I prevent it from firing or at least changing this behaviour? Are there any workarounds?

Hi,

 

 

I have 2 custom objects, Customer and Call Log. There's a lookup from Call Log to Customer. So, i have a related list 'Call Logs' on Customer detail page.

 

I have overriden the 'New' button on the related list, so when now the button is pressed, it redirects to the actual new record creation page, and also auto populates some values, including the lookup field to Customer with the name of the customer.

 

The code behind the button is:

 

/a07/e?CF00NA0000006AZ2f={!Customer__c.Name}&retURL=%2F{!Customer__c.Id}&RecordType=012A000000177i9&ent=01IA0000001TSOU

 CF00NA0000006AZ2f = the lookup field id (retreived from firebug)

 

Scenario:

 

Now, it works absolutely fine. But the thing is, since i am populating the lookup field with the name, if there are 2 customers by the name of "ABC", then both appear in edit page lookup field dropdown. The user is given an option to select one, and he, if sees the same name can select the incorrect one also.

 

 

Can anyone help me with this please?

 

Thanks,

Sumit

 

Hi,

 

In a master-child relationship between a standard object and custom object. Which of the following statements in NOT true.

Please select two items.

 

a) Standard object is always master

b) Custom object is always master

c) Custom object is always child

d) Standard and Custom object can be a master

e) Standard object is never a child

 

Which two options can be selected for this question?

 

Thanks and Regards,

Devendra S

 

 

I registered for 30 days free trial of the Unlimited Edition. I created a ptofile called LECTURER but when I created a New user. This user only has a User Lisence of  Salseforce Platform & Chatter Free BUT it does not have Salesforce User Lisence which will allow me select the LECTURER Profile for my new User. Why will the 30 days trial not give me the Salesforce User Lisence so that I can change the profile of my new User to LECTURER???

i think lead field is mapped in to opportunity,contact and Account. Is it possible to map the case field.

Q.1)You can map a custom lead field to a case.
  
 A.True (Correct Answer)
 B.False
 Explanation
you can map a custom object to a standard object

When I am running the Executable I see this error.

 

"Could not find the main class. Program will exit"

 

Any suggestions Please.

Hi all sorry if this isnt sposed to be posted in this section but im not sure where else to post it. Does anyone know why a custom report type wouldnt appear on the report types list? there are no filters so it should be showing everything.

 

Cheers Guys.

  • September 28, 2011
  • Like
  • 0

One user is not able to edit one dashboard others she can edit. Her profile has Manage Dashboard (All check box checked for Dashboard for her profile) and View All access still she is not able edit the dashboard.

 

Can somebody help me.

Hello,

 

I am currently in the process of trying to data remedaite URL's within our SFDC environment.  Using the Force.com IDE I thought I would be able to search within WebLinks or Components to find and replace the links I need to change.

I note there are links on my Home Page Components > Custom Links which do not appear within the "weblinks" or "components" in my Force.Com IDE.  Do you know where these would be stored therefore within the IDE?  I want to make sure I do not miss any links in my environment which i need changing.  Should Custom Links not exist within WebLinks?

 

Thanks in advance.