• Vipin_mittal
  • 0 Points
  • Member since 2011

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
  • 2



We have a Java application written in AXIS 1.4 connecting to a sandbox instance (https://test.salesforce.com/services/Soap/c/22.0/xxx) and perform a number of queries. The application runs fine most of the time. However, we got the following SSL handshake error intermittently:


Error occurred while logging in: java.lang.IllegalAccessException: Error occurred while logging in: ; nested exception is: 
	javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure

Does anyone encounter the same problem?


Any help is much appreciated.



  • September 23, 2011
  • Like
  • 0
I am trying to create a keystore (to be used in my web service client). I downloaded the client certificate from sales force and tried to run the keytool application.


keytool -import -file sfdc-client.cert -keystore sfdcclient.keystore -storepass sfdcclient -alias sfdc

Got the error java.lang.Exception: Input not an X.509 certificate

BTW I am using 1.4.1_05. Thought it might be the jre version. I remember reading that early version of 1.4 had some issues. So Tried doing the same thing with 1.5. Still got the same error.

Please help.

  • April 25, 2008
  • Like
  • 0