• S Shaw
  • 0 Points
  • Member since 2013

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 1
  • 8

Hi Experts,

I have developed a functionality on Force.com platform where I have written a VF Page that has Advance Search functionality. To do this, I have used Dynamic Query. It’s actually, building the Query as a String and then hit the Query using Database.Query(‘<String>’) method.

Now we are planning to package this functionality (with few more items) and put it in the App Exchange. We have done all of these and the Managed package is also ready. Now once the package is ready, I run the Security Check using CxViewer which gives the following Error:


1114. private Pagereference FilterSection() //cfmapadminsettings.cls
1234. if(strFilterLogic != null && strFilterLogic.trim().length() > 0 && lstCondtionNo.size() > 0)
1236. tempFilterLogic = strFilterLogic;
1247. strQuery = 'Select Id from Account where '+ tempFilterLogic + ' LIMIT 500 ';
1249. database.query(strQuery);


Its SOQL/SOSL Injection error due to the Dynamic query that we have created.

Can someone please suggest me how to resolve this issue or what is the second approach that I take to resolve it?


  • April 05, 2013
  • Like
  • 0

Hello Friends,

I am  having partner portal.In sales force i have created two lead layout. just say A and B.   A is for salesforce crm and B is for partner portal.When i am creating the lead from salesforce it is auto matically taking lead record type A. But when i am creating the lead from partner portal  i have to select record type from the picklist.
I dont want the record type picklist  or just default value B(not editable) .

How can i do the same????????


  • April 05, 2013
  • Like
  • 0

Hi All,


In my client sandbox org I  have intalled my package.


Assume in the package there is one VF page called XX  and Contoller for this page is YY.

this page is used to create the new record for one custom object .There is one save button in the XX page.


Right now the save button is not working. I have tried with the 'developer console'  and 'debug'

but i couldn't see any error in the log and also not much info in the log.


Please help how to get the error message in the Log.


Thanks in advance.


Hi -


I am getting an error when clicking a custom javascript button from a related list on Case in the service console, but only in Internet Explorer (8). Chrome works fine.


The error is: faultstring"INVALID_SESSION_ID: Invalid Session ID found in SessionHeader: Illegal Session"


The button is:

{!REQUIRESCRIPT("/support/console/27.0/integration.js")} //Chrome worked without this, not sure if it is doing anything now

var profile = "{!$Profile.Name}";
var LockedBy = "{!Case.Locked_ById__c}";
var CompletedBy = "{!Target__c.Completed_By__c}";
var Now = new Date();
var t = new sforce.SObject("Target__c");
t.id = "{!Target__c.Id}";

if(profile.search("Service")>=0 || profile.search("System Administrator")>=0) {
	if("{!Case.Locked_ById__c}" == "{!$User.Id}") {
		if(CompletedBy=="") {
			t.Completed_By__c = "{!$User.Id}";
			t.Date_Completed__c = Now;
                        sforce.connection.init('{!$Api.Session_ID}', 'https://ap1.salesforce.com/services/Soap/u/27.0'); // have tried several things in here. Chrome works fine without this line at all.
			result = sforce.connection.update([t]);
//and so on...

 I have made many attempts at solving this with no luck so far.


Thanks in advance for any assistance,


  • April 04, 2013
  • Like
  • 0