• dannapareddy1.3909373019751619E12
  • NEWBIE
  • 0 Points
  • Member since 2014

  • Chatter
    Feed
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
    Questions
  • 3
    Replies
Hi , 
I am calling a Webservice from salesforce . 
The End point was Http earlier and worked fine. Now the endpoint URL is changed to HTTPS.
I tried changing the end point and i received this error.
So i regenerated the Apex Class files and made a call to https:// and i see the error above.

Please suggest me how can i work arround this . The Http end point no longer exist and is only Https going forward. 


Thanks
Hi All, 

I am constructing a string with pipe in string . I get the HTML code of the string . please let me know how to get around this 



Execute Anonymous: String s1 = 'https://XXXX.com/deals/search?q=createdBefore:2011-12-30|status:XXXXX|city:XXXX';
Execute Anonymous: system.debug(s1);
16:17:38.038 (38016569)|EXECUTION_STARTED
16:17:38.038 (38030801)|CODE_UNIT_STARTED|[EXTERNAL]|execute_anonymous_apex
16:17:38.038 (38922735)|SYSTEM_METHOD_ENTRY|[3]|System.debug(ANY)
16:17:38.038 (38963804)|USER_DEBUG|[3]|DEBUG|https://XXXX.com/deals/search?q=createdBefore:2011-12-30|status:XXXXX|city:XXXX
16:17:38.038 (38982944)|SYSTEM_METHOD_EXIT|[3]|System.debug(ANY)



The pipe in the string is being changed to |

please help me get around this .This is the endpoint URL i need to make an webservice call out
Hi All, 

I am constructing a string with pipe in string . I get the HTML code of the string . please let me know how to get around this 



Execute Anonymous: String s1 = 'https://XXXX.com/deals/search?q=createdBefore:2011-12-30|status:XXXXX|city:XXXX';
Execute Anonymous: system.debug(s1);
16:17:38.038 (38016569)|EXECUTION_STARTED
16:17:38.038 (38030801)|CODE_UNIT_STARTED|[EXTERNAL]|execute_anonymous_apex
16:17:38.038 (38922735)|SYSTEM_METHOD_ENTRY|[3]|System.debug(ANY)
16:17:38.038 (38963804)|USER_DEBUG|[3]|DEBUG|https://XXXX.com/deals/search?q=createdBefore:2011-12-30|status:XXXXX|city:XXXX
16:17:38.038 (38982944)|SYSTEM_METHOD_EXIT|[3]|System.debug(ANY)



The pipe in the string is being changed to |

please help me get around this .This is the endpoint URL i need to make an webservice call out

Hi,


I am trying to insert a pipe symbol in a string for using the google chart apis. Unfortunately, SFDC is replacing the | symbol with |
Is there a way that we can have a string which includes the | symbol?
 
Doing system.debug('|'); in the developer console displays the output as
USER_DEBUG|[1]|DEBUG||
 
Any help is appreciated.

I have an IF statement that needs to read

 

"New monthly rate going forward is $1,000.00"

 

My formula is

 

IF(ISBLANK( Custom_Description__c ),
"" ,
"New monthly rate going forward is" &""& Opportunity__r.Current_Monthly_Revenue__c)

 

but the Opportunity__r field is a currency field and the formula Error says "Incorrect parameter for function &(). Expected Text, received Number

 

Thank you in advance

  • July 12, 2010
  • Like
  • 2