• Leo Santillan
  • NEWBIE
  • 35 Points
  • Member since 2015

  • Chatter
    Feed
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
    Questions
  • 2
    Replies
I'm trying to schedule a couple of Apex Classes to run weekly.

When I attempt this in our "Sandbox" environment I can go to Develop > Apex Classes > Schedule Apex and the available Apex Classes appear but when I try this in the "Live" environment no Apex Classes are available to schedule (they appear in the Apex Classes section but do not appear in the Schedule Apex section)

The message returned says
No records found due to one of the following:
  • There are no records of this type
  • You don't have permission to see any of the records

I have admin rights and I've tried to schedule them using our other admin users login details but with no luck.

Is this a problem with my access rights (and how do get the necessary access rights) or is there something obvious that I'm missing?

Many thanks

Alec

I am trying to deploy one class which has implemented Schedulable interface.

But when I try to deploy it using ANT I am getting the following error :

"Schedulable class has jobs pending or in progress".

 

I am waiting for this to get resolved since more than 48 hrs and it doesn't seem to resolve.

What can be done in such case? How to deploy it to production? I tried to deploy by making packages but could not since the components in the package already exist in production and gives an error when I unzip the package. Please suggest what can be done in this situation.

  • March 26, 2010
  • Like
  • 0