• PhyoPine
  • 9 Points
  • Member since 2015
  • Senior Manager
  • Groundswell Cloud Solutions

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 3
  • 10
Anyone having the problem? I was able to login to trailhead yesterday but today when I tried to login, I got the following errors. Really strange I can see my User Id and I think it is not supposed to happen. 

User-added image
User-added image
I was following trailhead Visualforce Mobile module with Angular + Ionic for IonicConacts pages as mentioned in tutorial. I couldn't make the page to display. After very long while I figured out when I checked Developer Mode in my setting, the contents didn't display but when I turn it off, the contacts displayed.

Is that some kind of a bug or am I missing something? Is it possible to use Ionic + Angular while Developer mode is on?
Hi all,

Anyone knows Admin 201 exam is available for Winter 16 release yet? When I go to official site ( http://certification.salesforce.com/administrators )
and download the Study Guide, it said Summer' 15.

Thinking of registering for exam only when Winter'16 release is ready.

Any thoughts?

Thanks in advance.
I am receiving this error message:
Step Not yet complete... here's what's wrong: 
An update to a Battle Station record with Weapon Status of 'Fully Operational' failed to post a Chatter message to the record. Make sure that the process is configured correctly and that it is activated. 
Note: you may run into errors if you've skipped previous steps.

The Validation rule is correct, the "Project Status' field update occurs correctly, the post is made to the chatter feed of the record (mine and the SF record that is used to verify the step) - and yet I get the error.
How should I troubleshoot this?

I trying to validate trailhead challenge " Quick Start: Heroku Connect Provision the Heroku Connect Add-on " but I have the error :
"Step Not yet complete... here's what's wrong:
The Heroku Connect Add on has not been setup correctly. "

I don't understand why, cause I've checked the listen and write option and selected the 7 fields in the mapping.
Moreover the contact is correctly updated in Salesforce.

I have tested with region Europe and also United States as mentionned here : https://developer.salesforce.com/forums/?id=906F00000005IX8IAM
but still the same error message.

Could you please advise ?
I was following trailhead Visualforce Mobile module with Angular + Ionic for IonicConacts pages as mentioned in tutorial. I couldn't make the page to display. After very long while I figured out when I checked Developer Mode in my setting, the contents didn't display but when I turn it off, the contacts displayed.

Is that some kind of a bug or am I missing something? Is it possible to use Ionic + Angular while Developer mode is on?
I'm donig - Creating Wizards with Visual Workflow - on Trailhead - I can get the account to create but not the contact or opportunity - can't figure out why - any thoughts?

Thanks for any help

I am new in Salesforce development. I am creating a simple reference check apps using  force.com sites.
I am done with the VF page. But how can I able to override the save button to do additional things like
go to the thank you page.

I am now catching up with the reading using apex and  some post recommends to create a SF class to do this.
Please give me idea how can I do this. Thanks in advance
The following challenge does not validate:

Quick Start: Lightning App Builder - Add Quick Actions and Activate the App
Error: One or more of the quick actions were not added to 'Field Sales App' 
So I'm fairly new to the Force.com platform.

That said, I'm working on doing some practical metadata backups and restores for our org and sandboxes using the ANT Migration Toolkit.
Using the IDE I'm able to quickly get the initial package.xml for *everything* and use it to retrieve the related metadata using the Migration Toolkit.
Everything is just wonderful until I retrieve all the metadata from one sandbox and try to deploy on another new sandbox within the same org.

Hundreds of cryptic errors (262 to be exact) occurred with a single deploy. Everything is correct between the orgs and my logins are working fine.

I was under the impression that this stuff just worked. Is it just me or are there other things that the documentation just doesn't tell you??


I'm attempting to code a list and I have the above error showing up whenever i attempt to compile the class.  Can anyone spot what Is wrong and tell me how to fix it?


Here's my page:

<apex:page standardController="SFDC_Purchase_Order__c" extensions="AttachPRTOPOController" action="{!initList}">
    <apex:form >
        <apex:pageBlock tabStyle="SFDC_Purchase_Order__c" >
             <apex:pageBlockTable value="{!resultList}" var="r"
                        id="resultsBlock" columns="9" width="20%">
                    // rendered="{!NOT(ISNULL(resultList))}">
                        <apex:column headerValue="PR No." width="5%">
                            <apex:outputLink value="/{!r.id}?retURL={$currentPage.URL}">{!r.Name}</apex:outputLink>
                        <apex:column value="{!r.status__c}"
                            headerValue="Status" width="5%" />"
                        <apex:column value="{!r.status__c}"
                            headerValue="Type" width="10%" />
                        <apex:column value="{!r.RecordType__c}"
                            headerValue="Item" width="5%" />
                        <apex:column value="{!r.Item_Requested__c}"
                            headerValue="new Item Description" width="15%" />
                        <apex:column value="{!r.New_Item_Description__c}"
                            headerValue="Quantity" width="15%" />
                        <apex:column value="{!r.Quantity__c}"
                            headerValue="Requested By" width="10%" />
                        <apex:column value="{!r.CreatedDate}" headerValue="Created On"
                            width="10%" />
                        <apex:column value="{!r.CreatedBy.name}" headerValue="Requested By"
                            width="15%" />

 and here is my class:

public with sharing class AttachPRTOPOController {
    private final SFDC_Purchase_Order__c myPO;
    public final string myUser = UserInfo.getUserID();
    public final PageReference myParentPage = ApexPages.currentPage();
    public List<tempPR> resultList {get;set;}
    public List<SFDC_Purchase_Requisition__c> castRequestList {get; set;}
   	public AttachPRTOPOController(ApexPages.StandardController con) {
        this.myPO = (SFDC_Purchase_Order__c)con.getRecord();
    public PageReference initList(){
        if(resultList == null  || resultList.size()<1) {
            resultList = new List<tempPR>();
        System.debug('*************************************************starting InitList resultList = ' + resultList.size());
            string inputVar = ApexPages.currentPage().getParameters().get('id');
            System.debug('*************************************************************************************************Inside initList now');
             string qry = 'SELECT id, Name, Department__c, Status__c,RecordType Request_Date__c,SFDC_Purchase_Requisition__r.Item_Requsted__c, New_Item_Description__c,' 
                 + 'Quantity__c from SFDC_Purchase_Requisition__c where Purchaser__c.id = :myUser order by name asc limit 200';
            castRequestList = Database.query(qry);
            System.debug('castAccountList = ' + castRequestList + 'size = ' + castRequestList.size());
            for(SFDC_Purchase_Requisition__c myPR :  castRequestList) {
                resultList.add(new tempPR(myPR));
                System.debug('**********************************************************************************Building castAccountList myPR = ' + myPR);
        return null;
    public List<tempPR> getRequests() {
        if(resultList == null) {
            System.debug('**********************************************************************************************Inside getAccounts resultList = null');
       System.debug('**************************************************************************************resultList returned from getAccounts' + resultList);
        return resultList;

    public PageReference processSelected() {
        System.debug('****************************************************************************************************Entered processSelected');
        for(tempPR tPR : getRequests()) {
            if(tPR.selected) {
                system.debug('******************************************at selectedAccount constructed: ' + tPR);
                system.debug('******************************************resultList = ' + resultList);
        return null;
       public class tempPR {
            public SFDC_Purchase_Requisition__c request {get; set;}
            public Boolean selected {get; set;}

        public tempPR() {

        public tempPR(SFDC_Purchase_Requisition__c req1) {
            request = req1;
            selected = false;

 Since I'm not very experienced, I know there are probably other problems with my code, but this is the one I'm having no luck in solving on my own.  I've tried replacing the quotes in the <apex:page> code with single quotes (didn't work, of course, since visualforce requires the double  quotes) and using a plain text editor to insert double quotes (char 34) over the double quotes that are there. I would be very grateful for any help anyone can offer.


Thank you in advance,