• Sandip Kana
  • 0 Points
  • Member since 2019

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 1
  • 1
We have recently started to migrate our service team from the Classic service console to the Lightning service console. One of the components we are trying to re-configure in the lightning environment is the email composer.

We have identified a number of issues with the console that we were hoping to rectify with a new email composer in lightning.

The issues that we identified were as follows:

1. Email composer is too small.
2. When user selects template they are shown "My templates" initially from the template selector.
3. Default template is not automatically replaced when a user selects a template.

These issues we were able to resolve with our Salesforce Developer who was able to create a new composer within our testing environment.

However, we have now encountered a new issue with the rich text editor within the tool bar to edit the HTML templates; the issue is that despite the template loading correctly we are not able to edit the text within the template using the toolbar. 

Our developer has tried a number of different integrations to try and resolve the issue, but she has not been successful so far.

Can anyone suggest a workaround for being able to edit the HTML template through the rich text editor or another means of creating an email composer?


This is the trailhead questions which I am trying to solve :

Create an Apex class that returns an array (or list) of formatted strings ('Test 0', 'Test 1', ...). The length of the array is determined by an integer parameter.The Apex class must be called 'StringArrayTest' and be in the public scope.
The Apex class must have a public static method called 'generateStringArray'.
The 'generateStringArray' method must return an array (or list) of strings. Each string must have a value in the format 'Test n' where n is the index of the current string in the array. The number of returned strings is specified by the integer parameter to the 'generateStringArray' method.

Here is my code :

public class StringArrayTest {
    public static List <String> generateStringArray (Integer n) {
       List<String> List1 = new List<String> ();
        for(Integer i=0;i<n;i++) {
          List1.add('\'Test'+ i+'\'' );
        return List1;


I am getting following error :

Challenge not yet complete... here's what's wrong: 
Executing the 'generateStringArray' method failed. Either the method does not exist, is not static, or does not return the proper number of strings.

I tried it many times but I am not able to solve this problem. Please help.