• Kristina Burns
  • 0 Points
  • Member since 2021

  • Chatter
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 1
  • 0
Hey All,

I've been searching for days for a solution to my problem. All I can seem to find is a couple people having a similar issue with no clear resolution. I set my OWD settings to "Public Read Only" for my accounts object. However, users who are not owners of the accounts can still edit the fields. So I thought ok, lets try setting it to "Private" and just share with a specific user role that has "Read Only" access. I ran into the same problem. The users in that role could still edit the fields on the account. My profile permissions are not set to "View All" or "Modify All." The profile object settings for Accounts are "create, read, edit" only. 

I'm not kidding when I say I've read hundreds of posts about sharing settings and permissions, and I genuinely have no idea what I am missing. And to make sure this wasn't something specific with the accounts object, I ran into the same issue with leads. This is maybe a huge error in my SF org or it is a small setting somewhere else that I have missed.

Please help!

I checked the "Sharing Hierarchy" and it is telling me the user should have "Read Only" access...but they don't.