• xpresslanej
  • NEWBIE
  • 30 Points
  • Member since 2009

  • Chatter
    Feed
  • 1
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
    Questions
  • 2
    Replies

I built a VF page to override the change lead status functionality. We require that a Reason Rejected field value is selected when setting the Lead Status = Rejected so I dynamically render the Reason Rejected when Rejected is selected from the select box. Everything works great...except when the user presses the button from a lead list view that is filtered by a Campaign. When they attempt to do so, instead of seeing my custom page, they get something like:

 

LastName, status FROM Lead WHERE ((CampaignId = '701T00000001cZo') ^ ERROR at Row:1:Column:83 No such column 'CampaignId' on entity 'Lead'. If you are attempting to use a custom field, be sure to append the '__c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names.

 

My VF page references the standard Lead controller. Do I really need to create a custom controller just to make this work?

 

Howdy everyone,

 

Well, I'm a bit stumped. I'm trying to test a web-to-lead form where I preset the record type:

 

 

<input type="hidden" id="recordType" name="recordType" value="012Q00000008ULW">

 

I have the "keep the existing record type" option set under Lead Settings and it is still not working. 

 

Everything else is populating correctly on the lead record in SFDC. 

 

Thoughts?

 

Thanks, 

 

Hi,

I was not able to enable the quote object.

Setup>Customize>Quote ==> There is no "quote" entry there.

How can I activate quotes for my developer account ?

Erwan 

  • February 26, 2010
  • Like
  • 0

Howdy everyone,

 

Well, I'm a bit stumped. I'm trying to test a web-to-lead form where I preset the record type:

 

 

<input type="hidden" id="recordType" name="recordType" value="012Q00000008ULW">

 

I have the "keep the existing record type" option set under Lead Settings and it is still not working. 

 

Everything else is populating correctly on the lead record in SFDC. 

 

Thoughts?

 

Thanks,