• Rebecca Ralls
  • NEWBIE
  • 10 Points
  • Member since 2014

  • Chatter
    Feed
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 3
    Questions
  • 9
    Replies
Hi there,

Conversation started here: https://success.salesforce.com/_ui/core/chatter/groups/GroupProfilePage?g=0F9300000001rzc&fId=0D53A00003fsbOX&s1oid=00D300000000iTz&OpenCommentForEdit=1&s1nid=0DB30000000072L&emkind=chatterCommentNotification&s1uid=0053000000A6wMv&emtm=1529343276536&fromEmail=1&s1ext=0

I am receiving a Too Many SOQL queries error from a process builder flow when I create > 100 Records at a time.  I thought Process builder was finally supposed to be properly bulkified as of Summer '18?

Here is my process. 

Owner update flow

It is REALLY straightforward.  It reassigns the owner on a record to match the owner of a record specified by a lookup field.  The field is "Entity" the process checks to make sure that the entity field has a value, and checks to see if the owner on the record maches the owner of the entity record.  If not, it updates the recor owner to match. It works perfectly as long as I only fire <100 records at a time.  But when I fire more records than that it fails. There is a slight possible catch in that the thing that "fires" (creates) the records on this object is a trigger from a managed package. The records on this object cannot be created manually, so I cannot test it,bBut I imagine it would be much the same if I uploaded too many records via dataloader.

I saw that this was a known issue here: https://success.salesforce.com/ideaView?id=08730000000DhBlAAK - but is says it was delivered in Winter '16.

Do i need to bite the bullet and create a trigger instead?

Any help or insight would be much appreciated. 
Thanks!
 
I came here to post because I'm tryingto complete the "Learn About regional settings" trailhead, but when I submit it, it tells me I have not completed the first step - when I definitely have.  Looking at many of the other posts today, other people are having similar problems on other trails.

Is trailhead experiencing a problem verifying work completed in trailhead playground orgs today?
Hi there,

I am working on a number of process builder and flow related processes that fire on objects that belong to a managed package.  When I fire the flow from the flow builder I get a nice verbose debug log that tells me exactly what's going on in every step of the fairly complicated flow.

When I fire the flow from an object involved in the managed package using a Process Builder trigger, all I get is about three lines in the debug log that says "Entering managed Package".  I don't get any information from workflow rules or process builder or visual workflow.

I talked to the vendor of the managed package, and they said that "the obfuscation of log output when entering our managed package code base i.e. an Apex Trigger which is a part of our managed package is an expected behaviour. Apex code external to our managed package does log output even if the trigger is defined on one of our packaged custom objects."  But it looks like maybe flow and WFR don't fall into the realm of "external Apex code.  ...

So I have 2 questions.  One - is this the expected behavior? And if not, is there any way to surface the debug logs for my processes? 

Thanks!!
Hi there,

Conversation started here: https://success.salesforce.com/_ui/core/chatter/groups/GroupProfilePage?g=0F9300000001rzc&fId=0D53A00003fsbOX&s1oid=00D300000000iTz&OpenCommentForEdit=1&s1nid=0DB30000000072L&emkind=chatterCommentNotification&s1uid=0053000000A6wMv&emtm=1529343276536&fromEmail=1&s1ext=0

I am receiving a Too Many SOQL queries error from a process builder flow when I create > 100 Records at a time.  I thought Process builder was finally supposed to be properly bulkified as of Summer '18?

Here is my process. 

Owner update flow

It is REALLY straightforward.  It reassigns the owner on a record to match the owner of a record specified by a lookup field.  The field is "Entity" the process checks to make sure that the entity field has a value, and checks to see if the owner on the record maches the owner of the entity record.  If not, it updates the recor owner to match. It works perfectly as long as I only fire <100 records at a time.  But when I fire more records than that it fails. There is a slight possible catch in that the thing that "fires" (creates) the records on this object is a trigger from a managed package. The records on this object cannot be created manually, so I cannot test it,bBut I imagine it would be much the same if I uploaded too many records via dataloader.

I saw that this was a known issue here: https://success.salesforce.com/ideaView?id=08730000000DhBlAAK - but is says it was delivered in Winter '16.

Do i need to bite the bullet and create a trigger instead?

Any help or insight would be much appreciated. 
Thanks!
 
I came here to post because I'm tryingto complete the "Learn About regional settings" trailhead, but when I submit it, it tells me I have not completed the first step - when I definitely have.  Looking at many of the other posts today, other people are having similar problems on other trails.

Is trailhead experiencing a problem verifying work completed in trailhead playground orgs today?
Guys we are getting multiple "Too many SOQL queries: 101" emails at the moment. We are using Classic.
We have not used any triggers just Process Builder for various functionality requirements. 
I have read on one of the ideas that this had been resolved and Process Builder is now "bulkified".
Can anyway guide me as to how we can resolve this
Would this only occur if there is a mass upload of records to the object where the Process Builder is built on?
  • August 17, 2017
  • Like
  • 0
Hi All, 

We are trying to edit an Auth Provider set (e.g. OpenID Connect) in our Sandbox environment however it returns the following error message:

Unable to Access Page
The value of the "Decryption Exception" parameter contains a character that is not allowed or the value exceeds the maximum allowed length. Remove the character from the parameter value or reduce the value length and resubmit. If the error still persists, report it to our Customer Support team. Provide the URL of the page you were requesting as well as any other related information.

Any help on this is greatly appreciated, thanks.
Hi there,

I am working on a number of process builder and flow related processes that fire on objects that belong to a managed package.  When I fire the flow from the flow builder I get a nice verbose debug log that tells me exactly what's going on in every step of the fairly complicated flow.

When I fire the flow from an object involved in the managed package using a Process Builder trigger, all I get is about three lines in the debug log that says "Entering managed Package".  I don't get any information from workflow rules or process builder or visual workflow.

I talked to the vendor of the managed package, and they said that "the obfuscation of log output when entering our managed package code base i.e. an Apex Trigger which is a part of our managed package is an expected behaviour. Apex code external to our managed package does log output even if the trigger is defined on one of our packaged custom objects."  But it looks like maybe flow and WFR don't fall into the realm of "external Apex code.  ...

So I have 2 questions.  One - is this the expected behavior? And if not, is there any way to surface the debug logs for my processes? 

Thanks!!