• Rich Fiekowsky
  • NEWBIE
  • 30 Points
  • Member since 2015
  • Developer
  • Middlesex Software

  • Chatter
    Feed
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 1
    Questions
  • 17
    Replies
I am trying to learn more about development. My Developer Edition org does not have the "Deploy" item in the Setup menus. Maybe this is normal, since there is not any Production system involved. But how can I practice preparing Change Sets and moving them to other orgs, such as my Trailhead playgrounds?  
I now see that my Trailhead Playground is acting up similar to others...and I thought it was just user error!
I too am experiencing the same messages:
"Please hold while our robots build your Trailhead Playground. This may take a few minutes" and
"Our robots are still working..." while trying to complete Module Trailhead Playground Management-2nd part Create a Trailhead Playground.
I am also unable to complete Module: Accounts & Contacts-2nd part Understand Account & Contact Relationships.
Actually I'm unable to complete any Trailhead that has a challenge because my Playgrounds don't work, are competing with each other or over-riding each other.
I have a couple of My Trailhead Playgrounds and also a Developer Edition Playground which I created under an email not connected to my SalesForce account. I am hoping there is a way to delete or fix the DE Playground. I'm honestly not sure why I even ended up in the Developer areas of SF since I am not at all a developer...
I really think that if I could just wipe the Developer area clean of my interactions, maybe Trailhead would be of some use for me as an admin. Can someone help me find where to submit this as a case to a support team that feels it is part of their responsibilities. I talked to a SFguy at the Trailhead learning center at the latest SalesForce Event held in Minneapolis (Fun!), and he said he had a similar experience and support had to go in and make some changes...hoping someone can help here...I really need this to be working correctly.
 
I properly installed CLI. In a command window, I enter:

sfdx force:auth:web:login -d -a DevHub

in order to log in to the trial Dev Hub that I created. The aforementioned command opens the Salesforce login page in the web browser, so I log in using my Developer Hub Trial Org credentials and click Allow. After that, web browser show me an error: "This site can't be reached. localhost took too long to respond".

This is the URL that Salesforce use after I authenticate in the browser: http://localhost:1717/OauthRedirect?code=aPrxbOND3gL_2LbSR7rKPdvD0XBVk2YpErl3pphY2f3xvZ1wf5SSPJByDleRLPMtzCQWnNGAdg%3D%3D&state=f2f8254fac23

I don't know what happen.

User-added image

User-added image

User-added image
Midway through this module the following Client Controller code is introduced.  Is the Reduce function documented anywhere else so I can understand it better.  The Trailhead explanation doesn't work for me, very stuck

({
    clickCreate: function(component, event, helper) {
        var validExpense = component.find('expenseform').reduce(function (validSoFar, inputCmp) {
            // Displays error messages for invalid fields
            inputCmp.showHelpMessageIfInvalid();
            return validSoFar && inputCmp.get('v.validity').valid;
        }, true);
        // If we pass error checking, do some real work
        if(validExpense){
            // Create the new expense
            var newExpense = component.get("v.newExpense");
            console.log("Create expense: " + JSON.stringify(newExpense));
            helper.createExpense(component, newExpense);
        }
    }
})


 
Hi,

Trailhead: https://trailhead.salesforce.com/projects/quickstart-lightning-components/steps/quickstart-lightning-components3

Problem saving MyContactList.cmp.
Field_Integrity_Exception: Failed to save MyContactList.cmp: Invalid definition for null:MyContactListComponent: null: Source

MCLC.apxc:
public class MyContactListController {
@AuraEnabled
public static List<Contact> getContacts(Id recordId) {
   return [Select Id, FirstName, LastName, Email, Phone From Contact Where AccountId = :recordId];
}
}

MCL.cmp:
<aura:component controller="MyContactListComponent" implements="flexipage:availableForRecordHome,force:hasRecordId" access="global" >
<aura:attribute name="recordId" type="Id" />
<aura:attribute name="Account" type="Account" />
<aura:attribute name="Contacts" type="Contact" />
<aura:attribute name="Columns" type="List" />
<force:recordData aura:id="accountRecord"
                  recordId="{!v.recordId}"
                  targetFields="{!v.Account}"
                  layoutType="FULL"
                  />
<lightning:card iconName="standard:contact" title="{! 'Contact List for ' + v.Account.Name}">
    <!-- Contact list goes here -->
</lightning:card>
</aura:component>

User-added image

Anyone any idea or suggestion to help?

Thank you, regards, albert
I don't know why, but Trailhead does not see that I've setup a user Samantha Cordero with the profile Field Sales User. I've create the Field Sales User profile, created the user Samantha Cordero, activate the user, generate a password, and logged in as the user. I even logged in as her in Salesforce 1, but I still get this message:
error message
Here is what her user detail page:
User-added image
Field Sales User profile:
User-added image
In the 'Customize Lightning Experience With Buttons, and Links' module on Traihead, I have created a custom detail page button and added it to the Account Layout page but I am not able to see the actions menu in the highlighted panel . The button is visible in the custom button section of the Account Page Layout but when I go to Account Record, I cannot see the actions menu. Please help me in resolving this issue.  
TIA
Custom button added on Account Page LayoutAccount Record
Hi,

While attempting trailhead App Development with Salesforce DX, I am trying to create a project using SFDX command as shown below:
User-added image

But I am getting a message which says the command is not available. Please help.

Regards,
Shyam Nair
Based on the exercice:
https://trailhead.salesforce.com/projects/flow_calculate/steps/flow_calculate_find

Within a dev org I have clicked on add a " New Flow". The screen is blank. All I can see if "Unsaved flow" with no activities available?

I will be looking for input to be able to finish the exercise.
Thanks Fred Flores
 
I keep receiving the following error message when attempting to clear:

"Challenge Not yet complete... here's what's wrong:  Could not find notification on dashboard. Please check the requirements again." 
(Task - Create a notification to alert you when lost opportunities exceed a certain amount)


The alert is created and set to run. When you Save and Run the alert, it disables it for some reason and you can't see it as a widget in  the Notification Tracking section. When you Save only, it stays active and displays the widget on the Wave Analytics home page. It doesn't display on the Oppty Details dashboard though.

Any thoughts? I'd like to complete this trail and progress to the next part of the project.

Working the "Handle Actions with Controllers" trailhead module and I'm not getting past the validation.
If I put the component in a test jig, I can see the button function and set the check box as expected.
 

Here is the code I'm using to set the item as packed...

component.set("v.item.Packed__c", true );

I'm assuming the validator does not like my syntax. Can you give me a hint to get past this?

Thanks.
John

I am working on the Creating & Using Custom Controllers module. I have tried this a variety of ways and I am still geting a "Challenge not yet complete....here's what's wrong:

"The outputLink component is not binding to the ID of a case"

Here is my code for the page:

<apex:page controller="NewCaseListController">
    <apex:repeat value="{!newCases}" var="case">
        <apex:outputLink value="/{!case.Id}">{!case.CaseNumber}</apex:outputLink>
    </apex:repeat> 
</apex:page>

And here is my code for the Apex Class:

Public class NewCaseListController {

    public String getCase() {
        return null;
    }

List<Case> results = new List<Case>();


private String sortOrder = 'CaseNumber';
public List<Case> getNewCases() {
    
    results = [SELECT Id, CaseNumber FROM Case WHERE Status = 'New'];

    return results;
    }
}

Feedback/Help :-)

Thank you, 

Orchid 


 
I have some custom Apex classes that are failing to save Opportunitty records when a certain flow is enabled in the process builder. When I disable the process in Process Builder, everything starts working again.

The error I get is:
Update failed. First exception on row 0 with id 0063800000WBq80AAD; first error: CANNOT_EXECUTE_FLOW_TRIGGER, The record couldn’t be saved because it failed to trigger a flow.

java.lang.IllegalArgumentException: unable to find field dataType for complex reference

Error is in expression '{!saveOpp}' in page editexecutivesummary: Class.OpportunityExecutiveSummaryController.saveOpp: line 128, column 1
I need some help figuring out why my Apex class is failing on all opportunities in any stage, as my process in Process Builder is not even suppose to fire until 'Closed Won' is TRUE.

The methos that is failing:
//METHOD: THAT SAVE THE OPPORTUNITY AND CALL THE CONGA MERGE.
    public PageReference saveOpp(){
        if(exe_summary != null && exe_summary.trim().length() > 0){
            opp.Executive_Summary_R__c = exe_summary;
            //exe_summary = exe_summary.replace('<p>','').replace('</p>','\n').replace('<br />','\n').replace('<br>','\n').replace('\'','');
            //exe_summary = exe_summary.replace('<[^>]+>',' ').replace('&amp;','&').replace('&lt;','<').replace('&gt;','>').replace('&quot;','"').replace('&#39;','\'').replace('&nbsp;',' ');
            opp.Executive_Summary__c = mergeFieldValues(exe_summary);            
        }
        
        if(!checkDouble(String.ValueOf(opp.Estimated_Travel_Costs__c))){
            opp.Estimated_Travel_Costs__c = 0;
        }
        update opp;
        return new PageReference('/apex/EditExecutiveSummary?updated=true&id='+opp_id).setRedirect(true);
    }



 
I'm getting the error "The outputLink component is not binding to the ID of a case" for this challenge. I've checked several threads on here and I'm almost certain it should be correct. It does link to the details page for the case. 

I initially just had the ID linking but have changed it so both case number and id link via id in case that mattered. 

I've also previously tried having a complete url as the value but no luck. 

Any help would be appreciated.

<apex:page controller="NewCaseListController">
 
        <apex:pageBlock title="New Case List" id="cases_list">
            
    <apex:repeat value="{! newcases }" var="cases">
       
        <apex:outputLink value="/{! cases.id}">
        ID:  {! cases.id }
        </apex:outputLink><br/>
        <apex:outputLink value="/{! cases.id}">
        Case Number:  {! cases.CaseNumber }
        </apex:outputLink><br/>    
    
    </apex:repeat>
            
        </apex:pageBlock>
I am having a hard time figuring this one out. Your suggestions would greatly be appreciated.
To complete this challenge, add a validation rule which will block the insertion of a contact if the contact is related to an account and has a mailing postal code (which has the API Name MailingPostalCode) different from the account's shipping postal code (which has the API Name ShippingPostalCode).Name the validation rule 'Contact must be in Account ZIP Code'.
A contact with a MailingPostalCode that has an account and does not match the associated Account ShippingPostalCode should return with a validation error and not be inserted.
The validation rule should ONLY apply to contact records with an associated account. Contact records with no associated parent account can be added with any MailingPostalCode value. (Hint: you can use the ISBLANK function for this check)
Hi I have configured Live Agent but it is not showing in Console App. I have made all settings correctly.

My console app
User-added image

I am trying to write a simple query to acces the Live Chat Transcript table.

I know the api name is LiveChatTranscript, but when I execute the following simple query:

SELECT * FROM LiveChatTranscript LIMIT 100

I get the following error:

'INVALID_TYPE: sObject type 'LiveChatTranscript' is not supported.


Is there something I have to do to make it queryable?  I have also noticed I cannot access it in the Apex Data Loader, which seems odd as well.