• Charmaine van der Merwe
  • NEWBIE
  • 10 Points
  • Member since 2015
  • Senior Analyst Programmer
  • Pepper


  • Chatter
    Feed
  • 0
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 2
    Questions
  • 6
    Replies
I get this error when I try to verify the second step for this badge:
Challenge Not yet complete... here's what's wrong: 
The '# of Volunteers Still Needed' field on the 'Volunteer Shift' record is not working as expected.
This is the formula I used:

MAX( Desired_nr_of_Volunteers__c  -   Shifts_Taken__c ,0)

Can someone please help?
I copied this code from the Trailhead page to create an Apex class:

User-added image

I get this error:
Error: Compile Error: Unexpected token 'list'. at line 2 column 15
Please help?
I get this error when I try to verify the second step for this badge:
Challenge Not yet complete... here's what's wrong: 
The '# of Volunteers Still Needed' field on the 'Volunteer Shift' record is not working as expected.
This is the formula I used:

MAX( Desired_nr_of_Volunteers__c  -   Shifts_Taken__c ,0)

Can someone please help?
I copied this code from the Trailhead page to create an Apex class:

User-added image

I get this error:
Error: Compile Error: Unexpected token 'list'. at line 2 column 15
Please help?
Hi All, 

Maybe I am missing something but I am going around in cirlces with the Contacts without Hobbies report. I have: 

1. Created a custom report type to get Contacts without hobbies 
2. Created an Account Value bucket field
3. Create a % Open Opps Formula 
4. Added First Name, Last Name, Total Opp Value, Open Opp Value, Phone, Email, %Open Opps to the report 
5. Summarised by Account Value then Account 

And im still getting an error: 

Challenge Not yet complete... here's what's wrong: The 'Contacts Without Hobbies' report is not configured correctly.

I have added screenshots of all the pieces - hoping someone else has hit this issue 

User-added image

User-added image

User-added image

User-added image
I am receiving this error message:
Step Not yet complete... here's what's wrong: 
An update to a Battle Station record with Weapon Status of 'Fully Operational' failed to post a Chatter message to the record. Make sure that the process is configured correctly and that it is activated. 
Note: you may run into errors if you've skipped previous steps.

The Validation rule is correct, the "Project Status' field update occurs correctly, the post is made to the chatter feed of the record (mine and the SF record that is used to verify the step) - and yet I get the error.
How should I troubleshoot this?