• RedSales
  • NEWBIE
  • 150 Points
  • Member since 2011

  • Chatter
    Feed
  • 5
    Best Answers
  • 1
    Likes Received
  • 0
    Likes Given
  • 53
    Questions
  • 56
    Replies

Hello,

 

I have a trigger in which I need to lookup fields using a lookup field.

If I debug/print out value of "Primary_Partner__c" in my trigger this works correctly.  However when I try to lookup fields using "Primary_Partner__r.Name" or similar for other fields I cannot find or obtain the values.  Is there a restriction in triggers from looking up a parent object or could this be related to some settings on the field?

 

Thanks

Hi, I'm trying to perform the following in a formula value in a workflow rule field update.

 

If value x is not null

 - update field with value x

else

 - update the field with value y

 

I tried this out using an If statement and Case statements but got errors both times.

is it true that an if statement can only return true or fase?  I can't say 

If (x not null), x, y

 

The above is just pseudocode but should outline what i am trying to do.

 

Any suggestions would be welcomed.

 

Thanks!

 

 

Hi, I wish to create a field of type "Email" and to populate this field with the Email address of the object creator. As there is a formula option when creating a field to populate the default value I thought I could use this to populate the field.  I therefore tried the following in the in the formula box for my Email Field.

 

CreatedBy.Email

 

However I get an error "Error: Field CreatedBy does not exist. Check spelling" when I try this out.

 

As formula fields can't be of type email I thought it would be handy if I could instead use the formula box/option in my Email Field to populate this.

 

Do you know if this should be allowed? If not will I require a workflow rule to populate this (it seems unnecessary to be honest).

 

Thanks in Advance. 

Hello,

 

I wish to update a lookup field from a workflow action however when I look at the options available for my field update teh options I have are "User", "Queue" or "Partner User". These require an actual name instead of a field lookup/reference.

 

Does anyone know how I can specify a field instead of an actual user or queue name for a field update?

 

Thanks!

Hello,

 

I have a workflow rule which I want to initiate from a formula field. I.E. when the field value changes (in the formula fiield) the workflow rule will be initiated based on the formula field matchig a specific criteria.

My question is, can this be done?

 

I read the following but it was posted quite a while ago therefore I'm not sure if it is still relevant.

 

http://success.salesforce.com/ideaview?id=08730000000BrHrAAK

 

Thanks for your help!

Hello,

 

I have a Picklist in which one of the fields is "Error". On a user changing form fields and choosing to choose a different picklist value I want a validation rule to check the previous value of the picklist field and to only allow certain values to be picked if previously at "Error".  I have tried the following.

 

OR(AND(PRIORVALUE(Request_Status__c)='Error' , Request_Status__c<>'Draft Request'),AND(PRIORVALUE(Request_Status__c)='Error' , Request_Status__c<>'Endorse'))

 

I receive an error as follows:

Error: Field Request_Status__c is a picklist field. Picklist fields are only supported in certain functions. Tell me more

 

The "Tell me More" link brings me to teh following article  https://avaya--c4rdev.cs12.my.salesforce.com/help/doc/user_ed.jsp?loc=help&target=tips_on_building_formulas.htm%23picklists_and_msps&section=Customizing

 

In which it states "

  • PRIORVALUE(Only in assignment rules, validation rules, workflow field updates, and workflow rules in which the trigger type is set to Every time a record is created or edited)"

I do want this to run though every time an edit occurs though so figured it should work.

 

Does anyone happen to know from looking at the above what I may be doing wrong and a way to get around this?

 

Thanks in advance.


Hello,

 

Within the Administration Setup section of SFDC there is an "Manage Users" section.  On searchging for and viewing a user record the "FederationIdentifier" field is not displayed to all profies viewing the user record.  I windered, how I can find out what profiles can view this field?  Field Level Accessibility does not seem to be available for this field therefore I'm not sure where this is set.

 

Thanks.

Hi,  I'm troubleshooting an error users are having withn a force.com web form.   The scenario is as follows:

 

- A user accesses the Force.Com site page

- He/She has many form fields, one of which is a field to browse to a file and to upload/attach this file.

- After selecting the file and hitting "Attach" the web form page refreshes and displays the filename of the file attached.  The file has been attached to the documents folder within SFDC.

 

- What is happening for larger files is that on clicking "attach"  the file is being uploaded to the Documents folder but the user receives an error message as follows in the web page.

 

"Authorization Required

You must first log in or register before accessing this page.
If you have forgotten your password, click Forgot Password to reset it. "

 

The page is a public facing page (not requiring any logins/authorization).  For smaller attachments the page refreshes ok with the new filename added after an attachment is made.  Do you know if there may be settings which is causing this error? As the file attaches/uploads ok to the documents folder I'm guessing there is no issue wtih filesize restrictions.

 

If you have any suggestons/thoughts on this and help would be appreciated.

 

Thanks! 

Hi,  I am trying to retrieve picklist values via apex using the following code.

 

List<SelectOption> optionList = newList<SelectOption>();

optionList.add(new SelectOption('', '- None -'));

Schema.DescribeFieldResult field = Product_Services__c.Service__c.getDescribe();

 

for(Schema.PicklistEntry f : field.getPicklistValues()) {

  optionList.add(new SelectOption(f.getValue(), f.getLabel()));

}

 

 

This works fine except it displays all the values available in the picklist. There is actually a controllingField "Product_Categories" which determines which picklist values should be displayed/used.

 

If I wish to use this controllingField and only display correct results for Product_Categories   "A" or "B" do you know how I do this?

 

Thanks.

Hello,

 

I have configured "My Domain" on our company's production environment and have been doing some testing using this domain.  If I wish to deploy the My Domain to all users (the final step in it's implementation) I wondered how long this takes to deploy?

 

Does anyone know the details in relation to this?

 

Thank you! 

Hi, I am working on a class in the Force.Com IDE.  The class compiles ok but when I try to save it to the server it states the class is dirty. This is ok & I understand there may be differences between my workspace & the server however I cannot find out what is causing it to be dirty. Is there a way of deterninining/viewing what within the class is "dirty"? is there a report or log for example within the IDE which contains such information?

 

Thanks

Hello,

 

I wish to search for a pharse within email templates on our environment.  In using the Force.Com IDE, I am trying to retrieve the email templates witin my project. I have deselected all other components/attributes within my project and wish to retrieve email templates alone.  However my IDE crashes out with jvm heap size errors after taking quite a while to try and retrieve contents.  

 

As an alternative I wish to search using the web ui but the search functionality does not seem to work as I require. If I choose "templates" or "HTML messages" within the search options, enter my search term and search it returns no matche. Even though I know the term exists.

 

Does anyone know if I am using the search functionality incorrectly when searching for email templates? Or have any further suggestions on how I can perform this task?

 

Thanks! 

Hello,   I have to change a class that was created 2 years ago by a different colleague. The current test code coverage is 88% for the class and there is no clear test class available that I can see which has produced this test coverage result.  Is there a way to detrmine how this test coverage was provided? I.E. which classes resulted in the test code coverage being provided to the class I wish to change?

Hello,

 

I am currently in the process of trying to data remedaite URL's within our SFDC environment.  Using the Force.com IDE I thought I would be able to search within WebLinks or Components to find and replace the links I need to change.

I note there are links on my Home Page Components > Custom Links which do not appear within the "weblinks" or "components" in my Force.Com IDE.  Do you know where these would be stored therefore within the IDE?  I want to make sure I do not miss any links in my environment which i need changing.  Should Custom Links not exist within WebLinks?

 

Thanks in advance.

Hi,

 

Within ym user object I have reference fields such as  "Approval Manager ". This field is a refence to the user object & by entereing a user id it displays the user's name as the manager.

I wish to set this value to empty using APEX code if data I retrieve (from a source external to SFDC) indicates no Approval Manager is provided.  I receive an error saying I'm assigning an invalid ID

 

my 2 lines of code are

 

usr.Approval_Manager__c='';

update usr;  

 

Does anyone know if I can set this to blank threfore?

 

Thanks

Hi,

 

I wish to instantiate a webservice call after I insert data into an object. I wondered how do I retrieve and pass a full object from within  a trigger to my webservice method call.

 

I had thought I could do something like this.

 

trigger MyObjDataAfterInsert on MyObjData__c (after insert) { 

  ProcessingService.processObjData(Trigger);

}

 

Where  "ProcessingService" is my webservice name (I changed the name for this forum)

However it does not compile ok.

 

How do i enter the pass my object within the   ProcessingService.processObjData(Trigger) method?

The Trigger.new method returns a list but I don't think this is what I need. I need to pass the full object within my method call.

 

Thanks!

Hi,  I've been looking through the following documentation https://login.salesforce.com/help/doc/en/sso_delauthentication_configuring.htm and note the following stated 

 

For security reasons, Salesforce restricts the outbound ports you may specify to one of the following:

  • 80: This port only accepts HTTP connections.
  • 443: This port only accepts HTTPS connections.
  • 1024–66535 (inclusive): These ports accept HTTP or HTTPS connections.

 

Do you know if this is still the case & if the documentation is therefore up-to-date and correct?  The webservice I am trying to connect to is on port 444 therefore I believe login errors I may be receiving are due to the above specifications.

 

Thanks for helping. 

Hi,  I wish to check the last modified date of some objects.  If I open these objects in the force.com ide it gives the data I opened them as the last modifed date. This is not the date the object was actually last modifed however as I have not made any changes to them.

In the WebUI I do not see a section to check the object itself as opposed to it's fields etc.  Do you know if there is a way of finding this out?  Thanks!

Hello,

 

I am required to edit a class which was created sometime ago by another developer.  In making my changes I've noted the previous developer had only provided a small % of test code coverage for the class therefore I wish to remediate this also.

if I try to run test coverage for one of the functions in the class I receive an error as follows "Future method cannot be called from a future method: "

The function therefore has an "@future" annotation before it's declaration.  To avoid this error I thought a possible workaround might be to check if I am executing the function from a test class & if so then to not set the "@future" annotation if so.

 

I would therefore use something like the following 

 

public class OppRegAsyncLead{          

  if (! TesterMethod.getInTestFlag()){       

    @future   

  }     

  public static void submitChildLeads(){   

     //Enter function logic here     

  }

 

  static testMethod void OppRegAsyncLeadTest(){     

    boolean inTest = true;   

    TesterMethod.setInTestFlag(inTest);    

    /Enter test class logic here 

  }


}

 

I get an error however as follows  "
Error: Compile Error: expecting right curly bracket, found 'if' at line 3 column 4"

 

This I guess is because I have an if statement directly after the class definition & do not have it within a method/function.

 

Does anyone know of a way I could possibly implement this workaround. I understand I should place my test method in a separate class & will do so once I know this workaround will work, however that is the step I wish to achieve first. Is there a way therefore to avoid setting a method as a future method for test class purposes?

 

Thanking you in advance.

Hi,

 

I wish to determine if there are specific URL's contained across the board within our custom buttons & custom links in our SFDC environment. Is there a way to search these objects/links?  I've been able to search through classes, triggers, pages, components..... using the Force.com IDE but I wondered if I could search through other such custom developed settings?

 

Similar to this, Can I search for content contained within Custom Components such as a HTML Area?

 

Thanking you in advance.

Hello,

 

I've noted in Salesforce.com url's that querystring parameters often contain the characters %2F  before an object. What is the purpose of these characters & what do they mean?

 

An example is the following "retURL=%2F01QQ1000007E4cm"

Where "01QQ1000007E4cm" is the object id.

 

Thanking you for your help.

Hi, I'm trying to perform the following in a formula value in a workflow rule field update.

 

If value x is not null

 - update field with value x

else

 - update the field with value y

 

I tried this out using an If statement and Case statements but got errors both times.

is it true that an if statement can only return true or fase?  I can't say 

If (x not null), x, y

 

The above is just pseudocode but should outline what i am trying to do.

 

Any suggestions would be welcomed.

 

Thanks!

 

 

Hi, I wish to create a field of type "Email" and to populate this field with the Email address of the object creator. As there is a formula option when creating a field to populate the default value I thought I could use this to populate the field.  I therefore tried the following in the in the formula box for my Email Field.

 

CreatedBy.Email

 

However I get an error "Error: Field CreatedBy does not exist. Check spelling" when I try this out.

 

As formula fields can't be of type email I thought it would be handy if I could instead use the formula box/option in my Email Field to populate this.

 

Do you know if this should be allowed? If not will I require a workflow rule to populate this (it seems unnecessary to be honest).

 

Thanks in Advance. 

Hello,

 

I wish to update a lookup field from a workflow action however when I look at the options available for my field update teh options I have are "User", "Queue" or "Partner User". These require an actual name instead of a field lookup/reference.

 

Does anyone know how I can specify a field instead of an actual user or queue name for a field update?

 

Thanks!

I tried a couple of times to install the Force .com plug-in for Eclipse Helios, but I got the same message. I would like to know if anyone can help me to figure out a solution.

I'm working on Windows XP Professional SP3 and Java.

java version "1.7.0_01"
Java(TM) SE Runtime Environment (build 1.7.0_01-b08)
Java HotSpot(TM) Client VM (build 21.1-b02, mixed mode, sharing)

 

Error message:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Problems downloading artifact: osgi.bundle,com.salesforce.ide.api,23.0.2.201201091635.
MD5 hash is not as expected. Expected: 97a6329f82c422a61e9b1bc28be7cace and found 0df4f6ef0bbf016fdf658a0e3dfd9dd7.
Problems downloading artifact: osgi.bundle,com.salesforce.ide.core,23.0.2.201201091635.
MD5 hash is not as expected. Expected: 1ac3f44231f25642a46a91575f99faf1 and found 518c4102c10d9dbb6bba66eafb28da9a.
Problems downloading artifact: osgi.bundle,com.salesforce.ide.documentation,23.0.2.201201091635.
MD5 hash is not as expected. Expected: e4d7099184e8010c5d235e7f328b2c31 and found eead8681e9a6dd15006612c107f37ef1.

 

Thanks in advance

Hello,

 

I have a Picklist in which one of the fields is "Error". On a user changing form fields and choosing to choose a different picklist value I want a validation rule to check the previous value of the picklist field and to only allow certain values to be picked if previously at "Error".  I have tried the following.

 

OR(AND(PRIORVALUE(Request_Status__c)='Error' , Request_Status__c<>'Draft Request'),AND(PRIORVALUE(Request_Status__c)='Error' , Request_Status__c<>'Endorse'))

 

I receive an error as follows:

Error: Field Request_Status__c is a picklist field. Picklist fields are only supported in certain functions. Tell me more

 

The "Tell me More" link brings me to teh following article  https://avaya--c4rdev.cs12.my.salesforce.com/help/doc/user_ed.jsp?loc=help&target=tips_on_building_formulas.htm%23picklists_and_msps&section=Customizing

 

In which it states "

  • PRIORVALUE(Only in assignment rules, validation rules, workflow field updates, and workflow rules in which the trigger type is set to Every time a record is created or edited)"

I do want this to run though every time an edit occurs though so figured it should work.

 

Does anyone happen to know from looking at the above what I may be doing wrong and a way to get around this?

 

Thanks in advance.


Hi,  I'm troubleshooting an error users are having withn a force.com web form.   The scenario is as follows:

 

- A user accesses the Force.Com site page

- He/She has many form fields, one of which is a field to browse to a file and to upload/attach this file.

- After selecting the file and hitting "Attach" the web form page refreshes and displays the filename of the file attached.  The file has been attached to the documents folder within SFDC.

 

- What is happening for larger files is that on clicking "attach"  the file is being uploaded to the Documents folder but the user receives an error message as follows in the web page.

 

"Authorization Required

You must first log in or register before accessing this page.
If you have forgotten your password, click Forgot Password to reset it. "

 

The page is a public facing page (not requiring any logins/authorization).  For smaller attachments the page refreshes ok with the new filename added after an attachment is made.  Do you know if there may be settings which is causing this error? As the file attaches/uploads ok to the documents folder I'm guessing there is no issue wtih filesize restrictions.

 

If you have any suggestons/thoughts on this and help would be appreciated.

 

Thanks! 

Hi,  I am trying to retrieve picklist values via apex using the following code.

 

List<SelectOption> optionList = newList<SelectOption>();

optionList.add(new SelectOption('', '- None -'));

Schema.DescribeFieldResult field = Product_Services__c.Service__c.getDescribe();

 

for(Schema.PicklistEntry f : field.getPicklistValues()) {

  optionList.add(new SelectOption(f.getValue(), f.getLabel()));

}

 

 

This works fine except it displays all the values available in the picklist. There is actually a controllingField "Product_Categories" which determines which picklist values should be displayed/used.

 

If I wish to use this controllingField and only display correct results for Product_Categories   "A" or "B" do you know how I do this?

 

Thanks.

Hello,

 

I have configured "My Domain" on our company's production environment and have been doing some testing using this domain.  If I wish to deploy the My Domain to all users (the final step in it's implementation) I wondered how long this takes to deploy?

 

Does anyone know the details in relation to this?

 

Thank you! 

Hi, I am working on a class in the Force.Com IDE.  The class compiles ok but when I try to save it to the server it states the class is dirty. This is ok & I understand there may be differences between my workspace & the server however I cannot find out what is causing it to be dirty. Is there a way of deterninining/viewing what within the class is "dirty"? is there a report or log for example within the IDE which contains such information?

 

Thanks

Hello,

 

I am currently in the process of trying to data remedaite URL's within our SFDC environment.  Using the Force.com IDE I thought I would be able to search within WebLinks or Components to find and replace the links I need to change.

I note there are links on my Home Page Components > Custom Links which do not appear within the "weblinks" or "components" in my Force.Com IDE.  Do you know where these would be stored therefore within the IDE?  I want to make sure I do not miss any links in my environment which i need changing.  Should Custom Links not exist within WebLinks?

 

Thanks in advance.

Hi,

 

I wish to instantiate a webservice call after I insert data into an object. I wondered how do I retrieve and pass a full object from within  a trigger to my webservice method call.

 

I had thought I could do something like this.

 

trigger MyObjDataAfterInsert on MyObjData__c (after insert) { 

  ProcessingService.processObjData(Trigger);

}

 

Where  "ProcessingService" is my webservice name (I changed the name for this forum)

However it does not compile ok.

 

How do i enter the pass my object within the   ProcessingService.processObjData(Trigger) method?

The Trigger.new method returns a list but I don't think this is what I need. I need to pass the full object within my method call.

 

Thanks!

Hi,  I've been looking through the following documentation https://login.salesforce.com/help/doc/en/sso_delauthentication_configuring.htm and note the following stated 

 

For security reasons, Salesforce restricts the outbound ports you may specify to one of the following:

  • 80: This port only accepts HTTP connections.
  • 443: This port only accepts HTTPS connections.
  • 1024–66535 (inclusive): These ports accept HTTP or HTTPS connections.

 

Do you know if this is still the case & if the documentation is therefore up-to-date and correct?  The webservice I am trying to connect to is on port 444 therefore I believe login errors I may be receiving are due to the above specifications.

 

Thanks for helping.