• Solees
  • NEWBIE
  • 357 Points
  • Member since 2012
  • Sales,Service, Dev and Adm Certified.
  • BLEIN Consulting


  • Chatter
    Feed
  • 11
    Best Answers
  • 6
    Likes Received
  • 0
    Likes Given
  • 38
    Questions
  • 156
    Replies
I am fairly new to Apex Development and am trying to debug some code developed by a senior level developer.
The code is a controller extension that errors with a SOQL limit without completing so the page is not completed.

I added system.debug statements to some of the methods in the code, turned on debug for my user and many different levels of debug but my system.debug statements fail to appear in the debug logs.  Based on other detailed entries in the debug log I have confirmed that the code where I've added system.debug is being executed.

Any suggestions?   I'm probably making a very simple/common beginner mistake.

Thanks
Debra
  • March 10, 2014
  • Like
  • 0

I would like a button on opportunities which can be clicked to update child opportunities

 

I have tried to adapt code I found on this forum but the below code updates the parent rather than the children. I don't have much javascript knowledge.

 

Child opportunities linked to parent opportunities via Parent_Opportunity__c lookup. Child Relationship Name is Child_Opportunities.

 

 

{!REQUIRESCRIPT("/soap/ajax/23.0/connection.js")}

try
{
var strQuery="Select Id from Opportunity where Parent_Opportunity__c = '" +'{!Opportunity.Id}'+"'";

var newRecords = [];

var otherP = sforce.connection.query(strQuery);
var records = otherP.getArray("records");
for(var i=0; i < records.length ; i ++)
{
	var ob = new sforce.SObject("opportunity");
        ob.Id = records[i].Id;
	newRecords.push(ob);
}
var thisOb = new sforce.SObject("opportunity");
thisOb.Id = "{!Opportunity.Id}";
thisOb.StageName= "{!Opportunity.StageName}";
thisOb.Status__c= "{!Opportunity.Status__c}";

var result = sforce.connection.update([thisOb]);
result = sforce.connection.update(newRecords);

alert(result);
location.reload(true);

}catch(er)
{
	alert(er);
}

 

  • October 31, 2013
  • Like
  • 0

Hi all,

 

I'm trying to update to the latest version of the SDK on Mac by running install.sh but keep getting the following error:

 

iOSShared.compile:
     [echo] installing PhoneGapLib for SDK iphoneos
     [exec] Build settings from command line:
     [exec]     INSTALL_ROOT = /Desktop/forcedotcom-SalesforceMobileSDK-iOS-6febcdd/external/callback-ios/sfdc_build/artifacts/PhoneGapLib
     [exec]     SDKROOT = iphoneos5.1
     [exec] 
     [exec] xcodebuild: error: '/Desktop/forcedotcom-SalesforceMobileSDK-iOS-6febcdd/external/callback-ios/PhoneGap/PhoneGapLib/PhoneGapLib.xcodeproj' does not exist.

 Do I need to manually install PhoneGap (again)?  Is anyone else getting this error?

 

Thanks!

  • May 28, 2012
  • Like
  • 0
Hello friends, i'm having an issue when trying to use the Partner WSDL to query information from account from one Salesforce ORG to another via Apex.  I'm using the WSDL2Apex to convert the XML and I get a success "Login" but i get the following error using "Query" if I use "SELECT Id, Name FROM Account" .

System.CalloutException: Web service callout failed: Unable to parse callout response. Apex type not found for element Name

The problem I think is that the next line never gets converted in Apex:
<any namespace="##targetNamespace" minOccurs="0" maxOccurs="unbounded" processContents="lax"/>

Is there a solution for this?  How can I make this less ironic? How is it possible that a Salesforce generated WSDL cannot be imported into Salesforce and work well?
  • March 24, 2017
  • Like
  • 0
Hello friends,

with the latest release of iOS10 and Salesforce 1 release, when I try to add a Custom Domain like a community, it's not working at all, I don't even get to the login page I get a 'not connected to the internet' message.  In iOS 9.3.5 and less I can achieve this with no problem.

What should I do?
  • September 29, 2016
  • Like
  • 0
Hello friends,
can anyone help us understand this "wierd" behavior from the SSO SAML2 we have implemented in a company.  

Steps for error:
1. User enters "My Domain" in chrome URL.
2. Automatically redirects to their Company ADFS log in page.
3. Writes down username and password correctly.
4. Redirection to Salesforce shows error of SSO.
5. If I look inside Salesforce in "Login History" page, there is no track of this attemp at all.

Steps for success:
1. User enters AFDS log in page.
2. Writes down username and password correctly.
3. User enters "My Domain" in chrome URL.
4. Successfully logs in to Salesforce.
5. If I look inside Salesforce in "Login History", there is track of this attemp.

What could be wrong in the AFDS?
Or in Salesforce?
  • August 09, 2016
  • Like
  • 0
Hello friends, we are having an issue with a customer with the SSO and his ADFS. We have uploaded correctly their certificate and metadata and we are getting the following error "Failed: Signature Invalid" but we don't know how to fix it.  We have tried changing our side and their side with no success. Please help us understand the issue.

This is the result the I have right now:
Results
Last recorded SAML login failure:  2016-04-20T21:56:33.750Z
Unexpected Exceptions
  Ok
1. Validating the Status
  Ok
2. Looking for an Authentication Statement
  Ok
3. Looking for a Conditions statement
  Ok
4. Checking that the timestamps in the assertion are valid
  Current time is after notOnOrAfter in Conditions
  Current time is: 2016-04-20T22:09:14.847Z
  Time limit in Conditions, adjusted for skew, is: 2016-04-20T22:04:34.275Z
  Timestamp of the response is outside of allowed time window
  Current time is: 2016-04-20T22:09:14.847Z
  Timestamp is: 2016-04-20T21:56:34.275Z
  Allowed skew in milliseconds is 480000
  Timestamp of the assertion is outside of allowed time window
  Current time is: 2016-04-20T22:09:14.847Z
  Timestamp is: 2016-04-20T21:56:34.275Z
  Allowed skew in milliseconds is 480000
5. Checking that the Attribute namespace matches, if provided
  Not Provided
6. Miscellaneous format confirmations
  Ok
7. Confirming Issuer matches
  Ok
8. Confirming a Subject Confirmation was provided and contains valid timestamps
  Ok
9. Checking that the Audience matches
  Ok
10. Checking the Recipient
  Ok
  Organization Id that we expected: 00DR0000001unHb
  Organization Id that we found based on your assertion: 00DR0000001unHb
11. Validating the Signature
  Is the response signed? false
  Is the assertion signed? true
  The reference in the assertion signature is valid
  Signature or certificate problems
  The signature in the assertion is not valid
  Is the correct certificate supplied in the keyinfo? false
12. Checking that the Site URL Attribute contains a valid site url, if provided
  Not Provided
13. Looking for portal and organization id, if provided
  Ok
14. Checking if session security level is valid, if provided
  Ok
  • April 22, 2016
  • Like
  • 0
Hello friends,

I am having an issue with Apex:Map component when the Visualforce is published inside Sites getting the "HTTP ERROR 401 Problem accessing /maps/JavascriptHandler. Reason: Unauthorized Powered by Jetty://".  1 of 20 tests is getting that error while refreshing the section that has the map inside and there is no way to reproduce it since it's random.  I think is something between google, Salesforce Sites and then the component.

Is there anything I can do about it?  The component works great while using it inside Salesforce platform but failing sometimes while using it in Sites.
  • March 14, 2016
  • Like
  • 0
¿Hello friends could anyone tell me how to use Office365 login as iDP to SSO Salesforce?  I cannot find any documentation regarding this and I need this for desktop and Salesforce 1.

Thanks
  • September 01, 2015
  • Like
  • 0
Hello friends,

I have Person Account activated and by default Contact OWD is Controlled by Parent, if I set Account to Private I expect to have Contacts Private.  But when 2 users have ownership of 2 different Contacts on the same Account, they both can see each other Contacts and I don't think this is the way it should be working.

A saw this issue being fixed on Spring 15 release but it's happening again.
https://success.salesforce.com/issues_view?id=a1p300000008XcJAAU

Hope other people have same problem and push the fix asap.
  • August 24, 2015
  • Like
  • 0
Hello friends,

i'm trying to upload a single file to chatter in a sandbox and I get the following error:
__MISSING LABEL__ PropertyFile - val CollabGroupDuplicateNameException_desc not found in section Exception

does anyone knows what I have to enable/disable to make the upload work again?
Am I the only one that gets error on Unit 1.  It's something simple and I get the error of 'Set Case to Escalated' worflow update field is missing... which is not, it's already there.

Cheers

 
  • December 03, 2014
  • Like
  • 0
Hello friends, does anyone knows or have an idea how to print a page from Salesforce 1 / Android ?

Thanks
  • October 13, 2014
  • Like
  • 1
Hello friends, hopefully someone in here will help me.  I'm using the Radian6 Engagement Console and I get the following error:

Radian6EC

Has anyone install it successfully ? thanks
  • October 01, 2014
  • Like
  • 0
Hello friends,

i've been trying to make work a WSDL2Apex having child namespaces different from the parent.  The solution is forget the WSDL2Apex since it will not add this namespace and the server will send you an error.  Save your time please, I already loose 8 hours trying and finding stuff related and nothing worked.

Use the HttpRequest instead !!!  And make the test in Developer ORG since there you can see the Request XML, other orgs won't work.

If you do this you won't need a Flat WSDL nor the requirements that Salesforce needs to import the WSDL.

So follow this steps:

1) Download SOAPUI
2) Create Project and import WSDL.
3) Get a success request and response.
4) Go to salesforce and create a Class that will send this SOAP callout.
5) Copy your SOAPUI request and paste it as a String.
6) Make changes for input variables.

This is an example of the Apex Code.


String s='<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:car="http://www.blabla.com/CargaCatalogosWS" xmlns:car1="http://www.blabla.com/CargaCatalogosHHType">'+
         '<soapenv:Header/>'+
         '<soapenv:Body>'+
           '<car:CargaCatalogosHHRequest>'+
              '<car1:CargaCatalogosHHRequest>'+
                 '<CANAL>'+canal+'</CANAL>'+
                 '<FECHA>'+fecha+'</FECHA>'+
              '</car1:CargaCatalogosHHRequest>'+
           '</car:CargaCatalogosHHRequest>'+
        '</soapenv:Body>'+
     '</soapenv:Envelope>';
   HttpRequest req = new HttpRequest();
   req.setEndpoint('http://www.blabla.com/wbi_FuncionCargaCatalogosHH');
   req.setMethod('POST');
   req.setBody(s);
   req.setHeader('Content-Type', 'text/xml');
   req.setHeader('SOAPAction', '"http://www.blabla.com/CargaCatalogosWS"');
   req.setHeader('Accept-Encoding', 'gzip,deflate');
   req.setTimeout(120000);
   Http http = new Http();
   HTTPResponse res = http.send(req);
  • September 12, 2014
  • Like
  • 0
Hello friends long time no see,

Is there a way to upload your .pfx file (private key and certificate) for WebService legacy integration, to Static Resource or Documents to later query it from Apex and then convert it into Base64 string?

Or the only way is to download Openssl and then execute "openssl base64 -in certifIF.pfx -out outputfile.txt" , then open it and copy the whole String?

Cheers

Hello friends, i want to send a mail before hitting the API limit, is this possible? The customer sure will appreciated.

 

Hope it can be done somehow.

 

Thanks.

  • December 09, 2013
  • Like
  • 0

Hi friends,

so again we had trouble with Jitterbit since there is no Documentation like Salesforce has.  If you are using Salesforce and you are trying to send Outbound messages be aware that they will be send in batch.

 

So in Jitterbit you have to create a Hosted Web Service, copy the URL to the Outbound Message, download the WSDL from the Outbound Message and upload it to the Hosted Web Service you created in Jitterbit.  Bit confusing but when you do it you'll get it right.

 

After the Hosted Web Service you need to create a Transformation that uses a File Format to 'save' in global variables the record.

 

In our case we needed to call a Stored Procedure (using script in jitterbit) afterwards and this is where we had the problems.  It only processed 1 record at a time even if the Outbound Message was sending more than once.

 

So the solution to this is the following:

1. Do no run the script with a 'on success' instruction of the first Operation (the Hosted Web Service).

2. Go back to the transformation where you are 'saving' in the global variables and go to the last one.

3. Run the next operation (the script that executes the SP) with this command: RunOperation("<TAG>Operations/Insert SP</TAG>", false);

 

And that one does the magic.

 

Have fun, Cheers.

  • August 29, 2013
  • Like
  • 2

Hi friends,

 

i'm posting this because Jitterbit does not have a lot of documentation about Salesforce.  If you ever need to send information from Salesforce through an Outbound Message to Jitterbit and you have Date/Time Fields, you will need the timezone since Salesforce sends the UTC time.  A work around that i found is this:

 

$SFFechaHoraActual=Date(LoginToSalesforceAndGetTimestamp("<TAG>Salesforce Orgs/admin@yourorg.com</TAG>"));
$SFFechaHoraActualCST=Date(FromDataLoaderDateTime($SFFechaHoraActual,"CST",true));
$TimeZoneDiff=Long($SFFechaHoraActualCST)- Long($SFFechaHoraActual);

 

Now you have the TimeZone in number and you could easy modify your date fields:

 

$SFFecha=if(IsNull($SFFecha) || $SFFecha=='', Now(), Date(Long($SFFecha)-Long($TimeZoneDiff)));

 

 

Cheers

  • August 23, 2013
  • Like
  • 0

Hello friends, long time no see.

 

I've just updated to the new SalesforceMobileSDK 1.4 for iOS and i want to change the SFAuthorizingViewController.xib and the SFNativeRootViewController.xib, how and where can i do this? in my AppDelegate.m?

 

I need to control this because i already have an iOS App using the 1.2 version and i used to do this in the SFNativeRestAppDelegate.m (

- (void)setupAuthorizingViewController method).  My App works for iPhone and iPad so i need this migrate this too.

 

    // Set up a view controller for the authentication process.

    SFAuthorizingViewController *authVc = nil;

    UIDevice *device = [UIDevice currentDevice];    

    if ([device userInterfaceIdiom] != UIUserInterfaceIdiomPad){

        authVc = [[SFAuthorizingViewControlleralloc] initWithNibName:@"SFAuthorizingViewControlleriPhone"bundle:nil];        

    } else {

        authVc = [[SFAuthorizingViewControlleralloc] initWithNibName:@"SFAuthorizingViewControlleriPad"bundle:nil];

    }

 

 

Thanks !!

  • February 08, 2013
  • Like
  • 0

Hi friends, how can i do this:

Schema.SObjectType.Account.getKeyPrefix();

 

but using javascript or sfoce ajax ?

 

thanxs

  • November 20, 2012
  • Like
  • 1

Hi friends,

 

im trying to upload some leads using Java and the REST API feature, but after all day fighting against the Charset UTF-8 and ISO-8859-1 , i found out  that when you try to upload a UTF-8 encoded json object with a special character in the Company field, it responds you with a 400 - bad request.

 

You can have special characters enconded in UTF-8 in any other field as FirstName, LastName, Street, City, Country, etc. this works and the lead will be uploaded, but if you have it in Company it will crash.

 

Does any body knows why is this ? It seems as a bug, or is something i need to configure in the ORG ?

 

thanks for watching

 

cheers

  • November 17, 2012
  • Like
  • 0

Hi friends im trying to learn about SAML2 settings in Salesforce and the only wiki i found was:

http://wiki.developerforce.com/page/Single_Sign-On_with_SAML_on_Force.com

 

but the sad part is that this document its really old, anyone has an update for this? about how to configure GlassFish and OpenSSO? im stuck in that part.

 

thanks

  • November 08, 2012
  • Like
  • 0
Hello friends, does anyone knows or have an idea how to print a page from Salesforce 1 / Android ?

Thanks
  • October 13, 2014
  • Like
  • 1

Hi friends,

so again we had trouble with Jitterbit since there is no Documentation like Salesforce has.  If you are using Salesforce and you are trying to send Outbound messages be aware that they will be send in batch.

 

So in Jitterbit you have to create a Hosted Web Service, copy the URL to the Outbound Message, download the WSDL from the Outbound Message and upload it to the Hosted Web Service you created in Jitterbit.  Bit confusing but when you do it you'll get it right.

 

After the Hosted Web Service you need to create a Transformation that uses a File Format to 'save' in global variables the record.

 

In our case we needed to call a Stored Procedure (using script in jitterbit) afterwards and this is where we had the problems.  It only processed 1 record at a time even if the Outbound Message was sending more than once.

 

So the solution to this is the following:

1. Do no run the script with a 'on success' instruction of the first Operation (the Hosted Web Service).

2. Go back to the transformation where you are 'saving' in the global variables and go to the last one.

3. Run the next operation (the script that executes the SP) with this command: RunOperation("<TAG>Operations/Insert SP</TAG>", false);

 

And that one does the magic.

 

Have fun, Cheers.

  • August 29, 2013
  • Like
  • 2

Hi friends, how can i do this:

Schema.SObjectType.Account.getKeyPrefix();

 

but using javascript or sfoce ajax ?

 

thanxs

  • November 20, 2012
  • Like
  • 1

Hi friends, do you know the code (Apex or Javacript) to open the Salesforce PDF Viewer but with a PDF i created manually? Not the templates you can create with salesforce.

 

cheers

  • October 18, 2012
  • Like
  • 2
Hello friends, i'm having an issue when trying to use the Partner WSDL to query information from account from one Salesforce ORG to another via Apex.  I'm using the WSDL2Apex to convert the XML and I get a success "Login" but i get the following error using "Query" if I use "SELECT Id, Name FROM Account" .

System.CalloutException: Web service callout failed: Unable to parse callout response. Apex type not found for element Name

The problem I think is that the next line never gets converted in Apex:
<any namespace="##targetNamespace" minOccurs="0" maxOccurs="unbounded" processContents="lax"/>

Is there a solution for this?  How can I make this less ironic? How is it possible that a Salesforce generated WSDL cannot be imported into Salesforce and work well?
  • March 24, 2017
  • Like
  • 0
Hello friends,

with the latest release of iOS10 and Salesforce 1 release, when I try to add a Custom Domain like a community, it's not working at all, I don't even get to the login page I get a 'not connected to the internet' message.  In iOS 9.3.5 and less I can achieve this with no problem.

What should I do?
  • September 29, 2016
  • Like
  • 0
We have a field "Renewal Date" which would read as say, 1/1/2016. I want to create a formula field that pulls the month out of that - preferably as the name of the month, so in the example "Jan" or "January". 
I'm trying to query VersionData to get a base64 representation of a file. It works in workbench (I get a really long field), but when I query it in my React Native sample app created with forceios (using SDK 4.3) I just get the following as the result:

/services/data/v36.0/sobjects/ContentVersion/{id of file}/VersionData

When I paste that URL into REST Explorer and do a get, I just get:

Raw Response
1


If I log into salesforce.com and paste that url after the .com, I get the following:
 
<Errors>
  <Error>
    <errorCode>INVALID_SESSION_ID</errorCode>
    <message>Session expired or invalid</message>
  </Error>
</Errors>

Any idea why this could be and how to get the data I want?  Thanks.
Hi,
I am looking to implement an alphabetical sidebar index in a VF page (class="list-group")  for Salesforce1 such as the one you find in your Contact List.
Do you have any idea where I can find code example?
Thank you.
Sylvie
Hi all,

I have added a "redirection.page" VF in the account layout. This internally (using a controller) redirects to another page based on the calculation in the controller. This works fine in Classic. However the issue is in Salesforce1, when the account detail page is loaded the entire page gets redirected to the next page from "redirection.page". The user is not in the account detail page anymore and he only sees the next vf page. Did someone face this issue? Please advice.

Manoj
Hello friends,
can anyone help us understand this "wierd" behavior from the SSO SAML2 we have implemented in a company.  

Steps for error:
1. User enters "My Domain" in chrome URL.
2. Automatically redirects to their Company ADFS log in page.
3. Writes down username and password correctly.
4. Redirection to Salesforce shows error of SSO.
5. If I look inside Salesforce in "Login History" page, there is no track of this attemp at all.

Steps for success:
1. User enters AFDS log in page.
2. Writes down username and password correctly.
3. User enters "My Domain" in chrome URL.
4. Successfully logs in to Salesforce.
5. If I look inside Salesforce in "Login History", there is track of this attemp.

What could be wrong in the AFDS?
Or in Salesforce?
  • August 09, 2016
  • Like
  • 0
Hello friends, we are having an issue with a customer with the SSO and his ADFS. We have uploaded correctly their certificate and metadata and we are getting the following error "Failed: Signature Invalid" but we don't know how to fix it.  We have tried changing our side and their side with no success. Please help us understand the issue.

This is the result the I have right now:
Results
Last recorded SAML login failure:  2016-04-20T21:56:33.750Z
Unexpected Exceptions
  Ok
1. Validating the Status
  Ok
2. Looking for an Authentication Statement
  Ok
3. Looking for a Conditions statement
  Ok
4. Checking that the timestamps in the assertion are valid
  Current time is after notOnOrAfter in Conditions
  Current time is: 2016-04-20T22:09:14.847Z
  Time limit in Conditions, adjusted for skew, is: 2016-04-20T22:04:34.275Z
  Timestamp of the response is outside of allowed time window
  Current time is: 2016-04-20T22:09:14.847Z
  Timestamp is: 2016-04-20T21:56:34.275Z
  Allowed skew in milliseconds is 480000
  Timestamp of the assertion is outside of allowed time window
  Current time is: 2016-04-20T22:09:14.847Z
  Timestamp is: 2016-04-20T21:56:34.275Z
  Allowed skew in milliseconds is 480000
5. Checking that the Attribute namespace matches, if provided
  Not Provided
6. Miscellaneous format confirmations
  Ok
7. Confirming Issuer matches
  Ok
8. Confirming a Subject Confirmation was provided and contains valid timestamps
  Ok
9. Checking that the Audience matches
  Ok
10. Checking the Recipient
  Ok
  Organization Id that we expected: 00DR0000001unHb
  Organization Id that we found based on your assertion: 00DR0000001unHb
11. Validating the Signature
  Is the response signed? false
  Is the assertion signed? true
  The reference in the assertion signature is valid
  Signature or certificate problems
  The signature in the assertion is not valid
  Is the correct certificate supplied in the keyinfo? false
12. Checking that the Site URL Attribute contains a valid site url, if provided
  Not Provided
13. Looking for portal and organization id, if provided
  Ok
14. Checking if session security level is valid, if provided
  Ok
  • April 22, 2016
  • Like
  • 0
Hello friends,

I am having an issue with Apex:Map component when the Visualforce is published inside Sites getting the "HTTP ERROR 401 Problem accessing /maps/JavascriptHandler. Reason: Unauthorized Powered by Jetty://".  1 of 20 tests is getting that error while refreshing the section that has the map inside and there is no way to reproduce it since it's random.  I think is something between google, Salesforce Sites and then the component.

Is there anything I can do about it?  The component works great while using it inside Salesforce platform but failing sometimes while using it in Sites.
  • March 14, 2016
  • Like
  • 0
¿Hello friends could anyone tell me how to use Office365 login as iDP to SSO Salesforce?  I cannot find any documentation regarding this and I need this for desktop and Salesforce 1.

Thanks
  • September 01, 2015
  • Like
  • 0
Hello friends,

I have Person Account activated and by default Contact OWD is Controlled by Parent, if I set Account to Private I expect to have Contacts Private.  But when 2 users have ownership of 2 different Contacts on the same Account, they both can see each other Contacts and I don't think this is the way it should be working.

A saw this issue being fixed on Spring 15 release but it's happening again.
https://success.salesforce.com/issues_view?id=a1p300000008XcJAAU

Hope other people have same problem and push the fix asap.
  • August 24, 2015
  • Like
  • 0
Hello friends,

i'm trying to upload a single file to chatter in a sandbox and I get the following error:
__MISSING LABEL__ PropertyFile - val CollabGroupDuplicateNameException_desc not found in section Exception

does anyone knows what I have to enable/disable to make the upload work again?
Hello friends, does anyone knows or have an idea how to print a page from Salesforce 1 / Android ?

Thanks
  • October 13, 2014
  • Like
  • 1

Hi friends,

 

im trying to upload some leads using Java and the REST API feature, but after all day fighting against the Charset UTF-8 and ISO-8859-1 , i found out  that when you try to upload a UTF-8 encoded json object with a special character in the Company field, it responds you with a 400 - bad request.

 

You can have special characters enconded in UTF-8 in any other field as FirstName, LastName, Street, City, Country, etc. this works and the lead will be uploaded, but if you have it in Company it will crash.

 

Does any body knows why is this ? It seems as a bug, or is something i need to configure in the ORG ?

 

thanks for watching

 

cheers

  • November 17, 2012
  • Like
  • 0

When i want to share a Content-Document a Link is created, how can i create and search for this link using API ?

 

cheers

  • October 17, 2012
  • Like
  • 0

Hi friends, is there any way i can Publish a Content-Document using API ?  and then query the Link it created to share it ?

 

I know its a hard question.

 

thanks

  • October 17, 2012
  • Like
  • 0

Hi there people, does any of you know how to change from an amount like "500 USD" to "five hundred USD" in Apex Code??