• NPM
  • NEWBIE
  • 320 Points
  • Member since 2006

  • Chatter
    Feed
  • 12
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 17
    Questions
  • 280
    Replies

Hi,

 

I am trying to setup an email alert through workflows when ever owner changes for the account.I am trying to to it using ISCHANGED(OwnerId) in rule criteria (formula evaluats to true)but it throws an syntax error saying Function ISCHANGED may not be used in this type of formula.

I want to know is there any work aroud for this Issue.

 

Any help is gr8ly appreciated.

 

I want to show the Contact Mailing City field on my Case Page Layout, but it is not an option to select.

Does anyone know a way to get this field to show on the Case Page Layout?

I ultimately want to add that field to the Cases Views so I can have a few cities use the same queue and this way they will be able to easily see which cases are for their city.

 

Thanks

 

 

 

I am attempting to create a validation rule that specifies if a certain value is selected in the Opportunity Stage picklist field it forces the owner to enter the contract duration before they can save the record.
Any help would be greatly appreciated.
Below is what I put together based on other rules I have in place on but cannot get it to work:
AND(
(Probability >= 0.50),
ISNULL( Length_of_Contract__c ))
Message Edited by Local Edge on 04-08-2009 08:45 AM

I have three fields Field A Field B and Field C

 

If Field  A is True then Field B is Required otherwise if Field A is False then Field C is Required. Can someone please tell me how to correctly write the formula, thanks.

I would like a URL to be visible on the Account, if the standard field "Rating" is set to "Customer". If any other value i.e. Prospect I do not want the URL to be visible. 

 

The URL is always the same and links (https address) to a common folder on  MS Sharepoint where we keep Customer information.

 

Even better - the URL could actually be different according to a logical value - Account Name. So if it possible to create a dynamic URL depending on Account name, that would be even better.

 

OR - is it even possible to create a link to our internal servers ? (Not URL link).

 

Why ?

 

When an account has become a "Customer", we store some information on it in folders on Sharepoint. It works to link to a folder (https-address), but I only want this link to be active on Accounts rated as "Customer" for many reasons.

 

Any idea ?

  • February 20, 2009
  • Like
  • 0

Hello,

 

  I am trying to create a field update for 2 fields in an object. One field is called status and is a picklist and the other field is called probability which is simply a percent field. I am trying to create a field update that says when status is changed to "completed", then make the probability equal to 100. Here is the formula I created below:

 

IF (ISPICKVAL( Status__c ,"Completed") , Probability__c = 100)

 

I am getting this error message: Error: Incorrect number of parameters for function IF(). Expected 3, received 2

 

Can somebody help me?

I have a picklist on a parent field with dropdown options from 1 through 50.

 

I want to have a formula on the child account which copies the same selection from the parent.

I have tried combinations of CASE, ISPICKLIST, OR and evrey other option to no avail.

 

Any suggestions? 

I'd like to create a workflow rule that automatically notifies certain people when an account owner is changed. I would also like to do this for the billing address. I can't figure out a way to base a workflow rule on a value in a field being modified. Has anyone been able to do this?

 

Thanks in advance!!

  • February 17, 2009
  • Like
  • 0

We operate with 5 currencies. These are available in a picklist for each account - Account Currency (CurrencyIsoCode), as well as when creating opportunities.

 

We would like to use the same Account Currency on all accounts (and not allow anything else than Euro). For the opportunities, we still want to keep the possibility to chose from the picklist and to keep them in local currencies.

 

The reason for this is that today, people mess up when creating accounts. They might choose GBP, and still enter Account Revenue in EUR - hence we can not classify our prospects from their revenue. We simply cannot trust the figures.

 

I´ve tried with ISPICKVAL(picklist_field, text_literal)   but this only allows me to return an errormessage on one false value. We need to omit 4 from the list.

 

Any idea ?

  • February 15, 2009
  • Like
  • 0

hi there,

 

does anyone know what the rule would be for something like this?  i'm struggling with the code:(

 

  • if this checkbox is checked, make these fields required
  • if this checkbox is unchecked, make these same fields NOT required 


or even better -

 

  • if this checkbox is checked, REVEAL these fields and make them required
  • if this checkbox is unchecked, HIDE these same fields and make them NOT required

 

 

Thanks so much!!

I need to create a workflow rule to alert a Business Unit Manager if the stage has changed on any of his 3 teams' deals for either of 2 specific types of Opportunities.

So there are 2 "OR" statements using PickVals. One is to determine if the Business Unit is one of his and another to determine if the Opportunity Type is one of two he wants to be alerted on.

And then I want the statement to be true if the Stage in one of these opps changes.



Here's what I came up with, but the syntax is wrong:

And(
OR(IsPickVal( BUOpportunityType__c ,"New Core Sale"),( ISPICKVAL( BUOpportunityType__c ,"Migration from Legacy Core"))),
OR(IsPickVal( OSI_Business_Unit__c  ,"CSG CU Sales - Major"),( ISPICKVAL( OSI_Business_Unit__c   ,"CSG CU Sales SME")),(OSI_Business_Unit__c , "OSC-BSG")))),
IsChanged(StageName)
)


Can someone help me fix this?

Thanks so much,
Jane


  • September 22, 2008
  • Like
  • 0
All,

I'm probably just not thinking clearly, but how can I require the completion of several fields based on the selection of a certain value in a picklist field?

I could do a series of Valudation rules (one for each field I need completed), but that sounds a bit inefficient . . .

Thanks!

I am not a developer but we had a developer create some Classes, Components and Pages for us in late 2008 that we put into but never used in production and do not plan to use anytime soon or ever.  We would like to export these out of our production org.  We see where we can download Classes to our file system and then we could delete the classes, but see nothing similar for Pages and Components.  How can we export the Pages and Component so we can also delete them from out production Org? 

  • April 07, 2010
  • Like
  • 0
Does anyone know if there is Salesforce Mail Merge support available/planned for Open Office?
  • December 09, 2009
  • Like
  • 0
Where can we look to get or how can we find a better description of the reason for an Outbound Messaging Delivery Failure? Below is what we get from Outbound Messaging Delivery Status page.  It truncates the specifics making for a lot of guess work/ trial and error.

System.Web.Services.Protocols.SoapException: Server did not recognize the value of HTTP Header SOAPAction: . at System.Web.Se

 

  • August 12, 2009
  • Like
  • 0

THere are display errors on the CRM Community site that have been verified by Support - who says they do not control that site and I should post the issue here.  Please see below Case 02695306: and also:

 

http://community.salesforce.com/sforce/board/message?board.id=discuss&thread.id=9359

 

Can someone fix this please?  It is hard to use the site as is.

 

 

 

6/5/2009 12:48 PM | Robert Montford
Thank you for your response. I was just able to test this out one on of our machines here, both in IE7 and in Firefox. The page shows the same as the screenshots provided, when using IE7. When using Firefox, it is formatted properly. This must be a coding or .css issue on the page.

As we do not actually control that site, your best bet at this point would be to mention this on the boards there. You may also want to post the same thing at salesforce.com/developer on the Discussion Boards tab.
 

 6/5/2009 12:07 PM | Neal Mengel
Oh- and the settings I went through were the ones outlined in Janet's email (the second one on the related list tasks.)

One of our developers has Chrome installed. ONce they get finshed with somethingthey are doing I will try with Chrome on their machine and post the results here.
 6/5/2009 11:55 AM | Neal Mengel
*.salesforce.com is and has been in my list of trusted sites.
I have used my computer at work (IE7) and my computer at home (IE7) - the same issue exists both places. I have no other browser I can use at work. I'm doubting it is my browser issue.
 6/5/2009 10:22 AM | Robert Montford
Thank you for your response, and your patience. It was not indicated on the case, but were the settings you went through our optimum browser settings for Internet Explorer? One thing to double-check would be to make sure all of Salesforce(*.salesforce.com) is added to your list of Trusted Sites. If you're still not displaying the Community pages correctly, there are a couple things I would like you to try. One would be to try a different browser (Mozilla Firefox, Google Chrome, etc..) to see if the same page loads correctly or not. Another thing to try would be to use another computer to view the same page. If you can try these, and let me know the results, that will help us narrow down where is issue is.

If you have any questions regarding this case, feel free to email me back at rmontford@salesforce.com and I will get back to you as soon as I can.
 6/5/2009 10:09 AM | Neal Mengel
Any progress update on this?
 6/2/2009 7:09 PM | Robert Montford
Thank you for contacting Salesforce Premier support. I have taken ownership of your case and will be working on it from here.

If you have any questions regarding this case in the meantime, feel free to email me back at rmontford@salesforce.com and I will get back to you as soon as I can.
 6/2/2009 8:39 AM | Janet Tyler
From: Fund Salesforce Admin <salesforce.fund.admin@gmail.com>
To: Janet Tyler <janet.tyler@salesforce.com>
cc:
bcc:

--------------------------------------------------------------------------------

Date: Tuesday, June 02, 2009 11:35AM
Subject: Re: Case 02695306: I am looking at a community page. [ ref:00D062.50036MkbF:ref ]




Hi Janet -

I went through all the suggested settings and made sure they are set as indicated. Closed and restarted the browser and got the same page display issue.

Attached are 3 screen shots that illlustrate the issues.

Related Attachments
 Attachment Name Size Last Modified
 3.bmp 739KB 6/2/2009 8:42 AM
 2.bmp 739KB 6/2/2009 8:41 AM
 1.bmp 729KB 6/2/2009 8:41 AM

  • June 08, 2009
  • Like
  • 0

Any ideas how to make the compile size smaller or otherwise accomplishe what I want?

 

I need to set a text type status formula field based on Effective Date and Expiration Date (Both are Date formats that are formula fields themselves derived from text fields with values like 20090527) .  This is what I have and the error message - I'd like to solve this without needing to wait for Summer 09 if possible.  Any ideas appreciated.

 

Error: Compiled formula is too big to execute (6,419 characters). Maximum size is 5,000 characters IF( AND( E_O_Policy_Effective_Date_Format__c < TODAY() , E_O_Policy_Expiration__c > TODAY() ), "1", "3")

 

 

  • May 27, 2009
  • Like
  • 0

This is using Mobile Lite.  We have several users using it with no problem.  I have a user that can download the client fine but the device will not Activate. Does anyone have any ideas?

  • May 04, 2009
  • Like
  • 0
WIthin the community discussions I am seeing some threads that the displayed text is running off the right hand side of the page before it wraps.  Other threads are displaying ok - word wrap is at the proper location.  I am using IE7, XPSP2.  I have set all the browser settings to the Salesforce recommended settings - no help.  Any ideas?
  • October 03, 2008
  • Like
  • 0
This morning we have users that have been routinely adding and updating events on our public calendars for the past several months suddenly not able to do so.  Premier Support/Admin is working and escalating to find out what is going on.  We are wondering if anyone else is/has been experiencing this?
  • September 23, 2008
  • Like
  • 0
I have a custom button we use to pass data from Events to a "Registrations" custom object.  It works great.  We want to add passing the Event Start Date/Time and End Date/Time but it seems to pass only the Date, not the time.  Any Ideas or insight you can add would be appreciated.  The applicable code:
Code:
&00N50000001kKSt={!Event.StartDateTime}
&00N50000001kKSy={!Event.EndDateTime}

 Where 00N50000001kKSt is a Registration custom field (Date/Time) called Start and
00N50000001kKSy is a Registration custom field (Date/Time) called End.
 
Only the Date is displayed in Start and End and the error message is :
Error: Invalid Date and Time

Appreciate any help with this.

 


 
  • September 12, 2008
  • Like
  • 0
As an EE customer we have an Apex/Configuration Only Sandbox available to us.  Can this sandbox be used to test integrations through the API? 
  • March 31, 2008
  • Like
  • 0
Need help with a formula, if it possible, to look at four checkbox fields and depending on which ones are checked set a text field with a code that is unique to each of the various combinations of whether these 4 checkbox fields are checked or not.  I am reaching a mind block, can someone help me out?
 
They checkboxes might be named Key, Target, Popular, Redone
 
 Example:
The user wants the Code field to be K, or T, or P, or R,or KT, or KP, or KR, or KTP, or KTR, or KTPR, etc. depending on which checkboxes are checked. 
 
Any ideas?
  • January 31, 2008
  • Like
  • 0
For Accounts (newly created or editing later) we want to populate a custom field (Member Number) automatically with a not-previously-used number.  But, We do not want to populate this field for all Accounts, just for ones we want to have member numbers generated (many of our Accounts are not members or are branches of existing members/member numbers).  We  need to
1.  create the Member Number and
2.  populate the field. 
We are wondering has anyone done this or what ideas there might be on how to do this?
  • August 03, 2007
  • Like
  • 0
Is it possible when using a custom link to run an advanced search to have the search look at only specified fields within the object?  For instance, I have a link on the Account detail page that runs an advanced search on Accounts and it uses a custom field value as the search criteria. The search returns Account records that have the value in any number of fields, thus usually returning more records than I am interested in.  I want to have the search return only records that have the specified value in a field or fields to be specified in the custom link.  Can this be done this way or in another way?
  • June 21, 2007
  • Like
  • 0
Is it possible when using a custom link to run an advanced search to have the search look at only specified fields within the object?  For instance, I have a link on the Account detail page that runs an advanced search on Accounts and it uses a custom field value as the search criteria. The search returns Account records that have the value in any number of fields, thus usually returning more records than I am interested in.  I want to have the search return only records that have the specified value in a field or fields to be specified in the custom link.  Can this be done this way or in another way?
  • June 21, 2007
  • Like
  • 0

I have a formula field called "Active Status" that displays an Image from the Documents object if Status = "Active". The image displays as expected on the Account Detail page, but not on the Search Results page. On that page instead of the image the small "red x" icon displays - even when I right click and select "Show Picture" the image does not display. How can I ensure the image displays on the Search results page as the idea is to highlight results with a particular status.

  • June 20, 2007
  • Like
  • 0
I have a formula field called that displays an Image from the Documents object if Status = "Active". The image displays as expected on the Account Detail page, but not on the Search Results page. On that page instead of the image the small "red x" icon displays - even when I right click and select "Show Picture". How can I ensure the image displays on the Search results page as the idea is to highlight results with a particular status.
  • June 19, 2007
  • Like
  • 0
How can I determine the API names for Account Billing Address Line 1, Billing Address Line 2, and Billing Address Line 3?  I can include these fields in a report but I need to populate them using the API and I need the field names for the mapping.xml.
 
 
  • April 26, 2007
  • Like
  • 0

I am not a developer but we had a developer create some Classes, Components and Pages for us in late 2008 that we put into but never used in production and do not plan to use anytime soon or ever.  We would like to export these out of our production org.  We see where we can download Classes to our file system and then we could delete the classes, but see nothing similar for Pages and Components.  How can we export the Pages and Component so we can also delete them from out production Org? 

  • April 07, 2010
  • Like
  • 0
Where can we look to get or how can we find a better description of the reason for an Outbound Messaging Delivery Failure? Below is what we get from Outbound Messaging Delivery Status page.  It truncates the specifics making for a lot of guess work/ trial and error.

System.Web.Services.Protocols.SoapException: Server did not recognize the value of HTTP Header SOAPAction: . at System.Web.Se

 

  • August 12, 2009
  • Like
  • 0

Hi All.

 

I have the following requirement -

 

I want a text to be displayed on the page that should be just a label, not to be associated with any field. It is a normal page and not a Visualforce page.

My text is about 200 characters (the character limit for field label is 50 chars and that for section label is 80 chars).

 

Can anyone suggest me the solution for this?

 

Any help will be GREAT :)

 

Thanks

I need to write a Data Validation rule to enforce users to use the Task Subject pick list values when creating tasks or activities.

 

I've started with this but need some help finishing it:

 

IF( Subject  <> "Call, Contacted, Conversation, Fax, Handoff, Interview, Left Voicemail, Mailed Collateral, Other, Send Email, Send Letter, Send Quote, Web Meeting , value_if_true, value_if_false)

 

Thank you,

  • June 18, 2009
  • Like
  • 0

Hi,

 

I am trying to setup an email alert through workflows when ever owner changes for the account.I am trying to to it using ISCHANGED(OwnerId) in rule criteria (formula evaluats to true)but it throws an syntax error saying Function ISCHANGED may not be used in this type of formula.

I want to know is there any work aroud for this Issue.

 

Any help is gr8ly appreciated.

 

I want to show the Contact Mailing City field on my Case Page Layout, but it is not an option to select.

Does anyone know a way to get this field to show on the Case Page Layout?

I ultimately want to add that field to the Cases Views so I can have a few cities use the same queue and this way they will be able to easily see which cases are for their city.

 

Thanks

 

 

 

I need to find a way to create an auto-incrementing version number for records created in my custom app.  I've created a product management database where product information is entered and modified over time.  When the record is intially entered, I'd like the version field to show "1".  Then if the record gets edited, I want the record to get saved with a new version number (2,3,4,etc). 

 

Can I do this using a custom field?

Hey guys, I'm an intern building a database for a real estate company and need some serious help.  I'm trying to create a field (specifically a date field) that when a date is added to the field, it triggers the next set of tasks.

 

Currently I have selected:

 

Eviction Scheduled (date field) is 'not equal to' ""

 

It isn't accepting "" as a null value so first wondering what null is in Salesforce's language.

 

 

When that didn't work I tried to create a formula that triggered when any date beyond May 1st, 2009 was entered (and was true).  No luck there either.

 

This was the formula:

 

REOHQ__REOHQ_Eviction_Scheduled__c > DATE(2009,5,1)

 

 

 

If anyone has any advice, I would be greatly appreciative of some help.

 

 

Thank you,

 

Ross Johnson 

 

We use a standard naming protocol when naming records on a standard object, i.e. Account Name - Date

 

I am trying to create a workflow, so that when a user creates a new custom object record and doesnt put the account name into the custom object Name field then a workflow is triggered. I want the workflow to update the name field to include the account name field + a date field + whatever was saved in the date field.

So the workflow would trigger if the 'Name' field does not contain 'Account' field, but i am struggling to put this into formula terms.

 

Am i going about this the correct way, or should i be using a trigger for this?

 

Any help would be great.

 

Matt

Message Edited by mstev45 on 05-08-2009 08:36 AM

This is using Mobile Lite.  We have several users using it with no problem.  I have a user that can download the client fine but the device will not Activate. Does anyone have any ideas?

  • May 04, 2009
  • Like
  • 0

Hi, I have this validation rule to prevent sales from overriding the forecast category:

 

or(
and(
case( StageName , "Requirements Analysis", 1, "Qualification", 1, "Proposal", 1, 2) < 2,
Not(ispickval( ForecastCategoryName , "Pipeline"))),
and(
text( StageName)="Negotiation",
Not(ispickval( ForecastCategoryName , "Best Case"))),
and(
text(StageName)="Closing",
text(ForecastCategoryName)<>"Forecast",
text(ForecastCategoryName)<>"Commit"))

 

 

The first two work perfect....

 

 

but the 3rd one (closing stage = commit

 

 and(
text(StageName)="Closing",
text(ForecastCategoryName)<>"Forecast",
text(ForecastCategoryName)<>"Commit"))

 

 

cannot work... I tried many ways to rephase the formula, without luck...

 

What is wrong?

 

  • April 10, 2009
  • Like
  • 0
I am attempting to create a validation rule that specifies if a certain value is selected in the Opportunity Stage picklist field it forces the owner to enter the contract duration before they can save the record.
Any help would be greatly appreciated.
Below is what I put together based on other rules I have in place on but cannot get it to work:
AND(
(Probability >= 0.50),
ISNULL( Length_of_Contract__c ))
Message Edited by Local Edge on 04-08-2009 08:45 AM
Hi,

I am looking for some help with the following:

I get the following error when attempt to send outbound message to my test server: javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated

- I have a real certificate installed on the server.
- I am also able to view the listener description when I point browser on my dev workstation to the test server (same URL as the endpoint specified in my O/B message).
- In the IIS log, I can see all the hits from my dev workstation, but no hits from either of SFDC IPaddresses (204.14....)

Appreciate any info that will help me understand and debug this, or at least point me in the right direction.

Thanks!