• Chris Duarte
  • SMARTIE
  • 1031 Points
  • Member since 2014
  • Editor-in-Chief, Trailhead

  • Chatter
    Feed
  • 9
    Best Answers
  • 10
    Likes Received
  • 0
    Likes Given
  • 3
    Questions
  • 216
    Replies
Hi There,

I'm having a hard time trying to validate the challenge of the module:
Lightning Flow
(step 3) Guide Users Through Your Business Processes with Cloud Flow Designer 

I followed every direction of the challenge, three times, removing eveything in between so I start from scratch again, but no, I still get this error message upon challenge validation:
Challenge Not yet complete... here's what's wrong: 
Can't find the forceContent:fileUpload Lightning component in the 'New Lead' flow. Make sure the field’s unique name is 'Upload_File'
Thing is this field does exist in the right named flow, called by the properly named home page. I don't get what I did wrong.
Flow Lightning Component field Upload_File

Any idea?
Can somebody please help me out here how to measure based on the sum of # instead of a count of rows or sum of the amount because on my case # is not appearing on the creating lens window Thanks in advance. PFB more details.

User-added image
In 'Analyze Your Data Over Time' in the Wave Desktop Exploration module, it says to Measure the sum of quantity (#) by chaning the Measure: Count of Rows to Sum of #. However, the # field does not exist so I cannot change it to this. Any help?

The Wave org was obtained through developer.salesforce.com/promotions/orgs/wave-de
The Salesforce1 Collaboration on the Go challenge doesn't work if you use https instead of http in the link you post Chatter, despite what the instructions say. Re-posting it with an http link solves the issue.

Error message

Screenshot of chatter post using https in link

Screenshot of instructions specifying https
I do not see any option on the page, however the challenge section says that 'This unit doesn't have a challenge. You can still earn points by marking the unit as read. Good job!' 
This is for Creating and Customizing Lightning Apps trail.

I am trying to use my regular production account to login to Trailhead.

I receive the following message:
Error
There was a problem with your authentication attempt. Please try again. If you continue to encounter problems, contact your administrator.
Trailhead Error with Production Login

I am the Administrator.

I created a case with Premiere Support.
CASE 12258260 - https://help.salesforce.com/apex/HTViewCase?id=5003000000a6RNUAA2&filterid=1 (https://help.salesforce.com/apex/HTViewCase?id=5003000000a6RNUAA2&filterid=1)

I know that I ought to be able to login with my PROD account and then link it to my personal DEV space (this login name).

Please advise. 

Thanks!

 

Getting this Error Dont understand what to do.

This is the challenge in Visualizing Your Data in the module of Report and Dashboards.
"
One or more of the following is incomplete in the Dashboard: no component uses the 'Cases by Status' report as a source report, your component does not have a 'Cases by Status' header, and/or your component does not have a 'New vs Closed' title.
"

I done all this thing correctly and also check many time but not finding solution.
User-added image+
User-added image
User-added image


Hope that this screen shot will help you to understan my problem.

Thanks in advance.
 
Is this happening to you? You're 100% sure you've done a Trailhead challenge right, but it just won't validate?

So here's the deal. We're doing a real-time API call to check your work, and sometimes, there might be existing configuration or code in your Developer Edition that interferes with our check, causing it to fail.

The best thing to do if you're 100% sure you're right is create a new Developer Edition and do the challenge again.

But wait, what about my badges?

No worries! Logging into Trailhead is a two-step process. Check out this image.

The login button is in the upper right, and the second login is on the unit page right before you do the challenge

In step (1), you tell Trailhead who you are. This is where your badges are stored. You can use your production username or any Developer Edition username for this step.

In step (2), you tell Trailhead where you're doing the challenge. This must be a Developer Edition.

Okay, I got the new DE. Now what?

So, just stay logged in at (1), and make a new Developer Edition to log in at (2). Do the challenge in the new Developer Edition and check it.

If it passes, it was probably something funky in your old DE. If it fails, time to revisit your challenge! Read the instructions again and make sure you didn't miss any steps.

But why would this happen?

It could be your DE is older, or it could be you've done some additional config or customization that is interfering with our check. 

Good luck!
Working on the Chatter Basics module for Trailhead, and having trouble uploading a photo to your Chatter profile?

Remember these tips:

1. Select a photo smaller than 8MB
2. Select a JPG, GIF, or PNG format

Still having trouble? Use this one! I tested this morning and it works. Plus it's adorable!

[a PNG file you can use for Chatter. It's a picture of our mascot, Astro, dressed in a furry raccoon suit]
Working on the Accounts & Contacts module in Trailhead, but don't see the Contacts tab in your DE? No problem! Just select 'Sales' from the App Menu in the upper right corner.

Go to the upper right corner and select the drop down menu. Then select Sales from the drop down menu list.

Voila! The Contacts tab appears!

The Contacts tab is now available across the top of the screen.
Is this happening to you? You're 100% sure you've done a Trailhead challenge right, but it just won't validate?

So here's the deal. We're doing a real-time API call to check your work, and sometimes, there might be existing configuration or code in your Developer Edition that interferes with our check, causing it to fail.

The best thing to do if you're 100% sure you're right is create a new Developer Edition and do the challenge again.

But wait, what about my badges?

No worries! Logging into Trailhead is a two-step process. Check out this image.

The login button is in the upper right, and the second login is on the unit page right before you do the challenge

In step (1), you tell Trailhead who you are. This is where your badges are stored. You can use your production username or any Developer Edition username for this step.

In step (2), you tell Trailhead where you're doing the challenge. This must be a Developer Edition.

Okay, I got the new DE. Now what?

So, just stay logged in at (1), and make a new Developer Edition to log in at (2). Do the challenge in the new Developer Edition and check it.

If it passes, it was probably something funky in your old DE. If it fails, time to revisit your challenge! Read the instructions again and make sure you didn't miss any steps.

But why would this happen?

It could be your DE is older, or it could be you've done some additional config or customization that is interfering with our check. 

Good luck!
Working on the Chatter Basics module for Trailhead, and having trouble uploading a photo to your Chatter profile?

Remember these tips:

1. Select a photo smaller than 8MB
2. Select a JPG, GIF, or PNG format

Still having trouble? Use this one! I tested this morning and it works. Plus it's adorable!

[a PNG file you can use for Chatter. It's a picture of our mascot, Astro, dressed in a furry raccoon suit]
Challenge Not yet complete... here's what's wrong:
Can't find the forceContent:fileUpload Lightning component in the 'New Lead' flow. Make sure the field’s unique name is 'Upload_File'
Hi There,

I'm having a hard time trying to validate the challenge of the module:
Lightning Flow
(step 3) Guide Users Through Your Business Processes with Cloud Flow Designer 

I followed every direction of the challenge, three times, removing eveything in between so I start from scratch again, but no, I still get this error message upon challenge validation:
Challenge Not yet complete... here's what's wrong: 
Can't find the forceContent:fileUpload Lightning component in the 'New Lead' flow. Make sure the field’s unique name is 'Upload_File'
Thing is this field does exist in the right named flow, called by the properly named home page. I don't get what I did wrong.
Flow Lightning Component field Upload_File

Any idea?
I have done the exact same thing as they have said in the module. But some how I am getting error like this: 
Challenge Not yet complete... here's what's wrong: 
Can't find the forceContent:fileUpload Lightning component in the 'New Lead' flow. Make sure the field’s unique name is 'Upload_File'
Though I have named the field as 'Upload_File'!!!

I am attaching the screen shot of how I have done it below..
My flow is also active and is also inclued in the page named "Process Automation Home". I don't know what is wrong. Kindly help me. 

User-added imageUser-added image
User-added image
So I have a trouble with Lightning Flow module in "Guide Users Through Your Business Processes with Cloud Flow Designer" theme. 
I have this error.
User-added image
But in Flow Designer Unique Name is right.
User-added image
Outputs tab is empty. Lightning runtime flow is enabled.
Have any idea to do with it?
Challenge Requirements:
Create a flow:
Name: New Lead
Type: Screen Flow
In the flow, add a screen with these required screen fields.
Last Name
Company Name
In the flow, create a lead record.
Use the screen fields to set the lead’s Last Name and Company.
Store the lead’s ID in a Text variable called leadId.
In the flow, add another screen with a Lightning component screen field.
Name the field Upload_File
Choose the forceContent:fileUpload Lightning component.
Use the leadId variable to set the component's Related Record ID attribute.
Activate the New Lead flow.
Create a new Lightning page:
Type: Home page
Label: Process Automation Home
In Process Automation Home, add a Flow component that references the New Lead flow.
Activate the page and set it as the default Home page.

I did all of this and yet it says it cannot detect force content?User-added image
User-added image
I am having a hard time getting past the Admin Intermediate "Guide Users Through Your Business Processes with Cloud Flow Designer " Challenge. I keep getting the error: Challenge Not yet complete... here's what's wrong:  Can't find the forceContent:fileUpload Lightning component in the 'New Lead' flow. Make sure the field’s unique name is 'Upload_File'

I've followed all of the directions exactly, get no errors when i'm building the flow and i've tried three different playgrounds and have cleared browser/history and restarted my browser between each one. I can't seem to get past this issue
User-added image
The challenge requires me to block all users' access to the Salesforce1 for iOS app or the Salesforce1 for Android app. Under my connected apps i can only see "Salesforce for iOS" and this was the one I blocked. I have verified that my Salesforce1 app session has been revoked.

When I submit my challenge it gives the following error:

"It doesn't appear that you've blocked all users' access to either the Salesforce1 for iOS or Salesforce1 for Android app. Please check again."

How can I get around this error? Would the fact that my connected app is simply called "Salesforce for iOS" (missing the "1") have anything to do with it?
Hi,
According to the requirement of Project  I have created Lense named worldwide_sales_with_flags. But still I am getting the error:User-added imageUser-added image
Challenge says "To pass this challenge, block all users' access to the Salesforce1 for iOS app or the Salesforce1 for Android app."

"Instructions say: From Setup, enter Connected Apps in the Quick Find box, then select Connected Apps OAuth Usage.
Click Block on the row for Salesforce1 for Android or Salesforce1 for iOS.
When you’re ready to reenable access to the app, click Unblock."

Now as  instructed in some other Challenge I have installed the Salesforce1 App on my Smartphone, which is an Android and have logged in and did looking around and stayed logged.



 From Setup, I entered Connected Apps in the Quick Find box, then selected Connected Apps OAuth Usage.
I only see Salesforce1 for Android as that is the only one I am signed into and so there is no Salesforce1 for iOS.listed.
I Clicked Block on the row for Salesforce1 for Android and I am promptly kicked off of my Salesforce1 App on my Andriod phone.
The option the Salesforce1 for Android nrow are UNBLOCK and UNINSTALL

So I run the challenge before unblocking the Andriod and it fails:

Challenge Not yet complete... here's what's wrong:
It doesn't appear that you've blocked all users' access to either the Salesforce1 for iOS or Salesforce1 for Android app. Please check again.

OK why is this ??  Is the challenge expecting you to have both an active Salesforce1 for iOS to block AND an active Salesforce1 for Android to block at the same time ??  That is not possible for me to do both at the same time.

I know I blocked the Salesforce1 for Android because I was kicked out of Salesforce1 on the phone and the Salesforce1 for Android wnet from users = 1 to users = 0. 
Can somebody please help me out here how to measure based on the sum of # instead of a count of rows or sum of the amount because on my case # is not appearing on the creating lens window Thanks in advance. PFB more details.

User-added image
I keep getting the "Challenge Not yet Complete......... Here's whats wrong"
Lightning page named 'New Account Page' does not appear to have the correct components on it.

The new record page must use the 'Header and Two Columns' template, be called 'New Account Page', and be assigned to the Account object. (Check this is done)
The page must have the Highlights Panel and Twitter components, and a Tabs component with these tabs containing these components: (Check this is done)
Activity Tab contains the Activities Component - Complete
Collaborate Tab contains the Feed Component - Complete
Related Tab contains the Related Lists Component - Complete
Details Tab contains the Record Detail Component - Compelte

Here is a screen shot, I believe I have all the items I am supposed to as well as what goes inside the components.
User-added image