• RyanGuest
  • SMARTIE
  • 1168 Points
  • Member since 2008

  • Chatter
    Feed
  • 42
    Best Answers
  • 0
    Likes Received
  • 0
    Likes Given
  • 0
    Questions
  • 268
    Replies

I am working in my dev org to allow access to a custom visualforce page through Sites.  The page displays a single Account and some related Custom Objects, and i made these accessible to the Guest User profile.  I was seeing the page but without details (though the Custom Controller is hard-coded to display a particular Account), so I decided to see what I could gain access to through using the Customer Portal.  The Customer Portal has access to even fewer objects than the Guest User (no custom objects at all), so that was a wrong move, but now although I deselected Login Enabled so that on the Sites detail page is reads 'Login - Not Allowed', the Guest User has no access at all - I get the 'Authorization Required' page.

 

I tried deactivating the Site and creating a new one, but my Dev Org only has one Sites license, even if the other is disabled.  And there is no way (that I can see) to delete the Site and start over.

 

So it appears that I am stuck with the Customer Portal: Contact Portal login.  I'm getting an error there as well, and no email is being generated telling me (in my Admin role) what the issue is.

 

Is there a way, through Eclipse perhaps, to delete the Site from Dev Org so that I can try again?

 

 

Hello everyone,

 

I'm researching force.com on behalf of a company in order to help them in the creation of their website. One of their requests is finding out 'what all is needed to make a force.com website?'

 

So far, I've determined that in addition to have a developer to work on the site, one of the necessities is to have either enterprise or unlimited editions of the platform, with the enterprise being for more small scaled projects such as for instance amazon.com with the centered focus of just selling items, while the unlimited edition is much larger scaled projects that have multiple features, such as google with it's map feature, it's mail feature, it's search feature and so on.

 

Additionally, another bit of information asked by my company are the best implementation methods to make a website.

 

If anyone would be willing to part with information or point me in a direction with answers I would be appreciative.

  • September 14, 2010
  • Like
  • 0

Hi all,

 

I want to ask a question. Is there any ways to make force.com sites access using salesforce login? I mean when another user access to that site, the user must login first before entering the force.com site. I don't want to use the customer portal.

Suggestions would be great.

 

Thanks

 

 

Hi can anybody help me how to write a URL rewriter class for my site in apex.

Hello,

 

I recently tried to add sites to my developer account, using the directions here: https://www.developerforce.com/events/sitespreviewsignup/registration.php

which should have added 'sites' development capability to my account.  After completion, I still did not have access ( did not see the new entry in the setup->develop list ).

 

I tried logging out, purging my cache, and logging back in. Anyone have other suggestions?  Should I just create a new developer account?

 

Thanks.

Hi,

 

I am trying to customize the site registration page, which comes out of the box.

when we put in our username,force.com appends customerportalid.na6.force.com to it. we could also login by just entering the username and no need to enter appended stuff.

 

But, what i am thinking is would it be possible to make username same as email, like the one we use for CRM login.

How can i accomplish this?

I tried writing a trigger on user object for after insert event and it quite did not work. Is there anything that i am missing.

Any ideas/help on this is highly appreciated.

 

trigger MatchUserNamewithEmail on User (before Insert) 
{
   
    if(Trigger.Isbefore && Trigger.IsInsert)
    {
        for(user u : Trigger.New)
        {
            if(u.userType.endsWith('PowerCustomerSuccess'))
            {
                if(u.Username!=u.email)
                {
                    u.Username=u.email;
                   
                }
            }
         }
     }
    
   

}

Thanks,

sales4ce

how can we check the debug logs of guest users

Hi all,

 

when I am clicking on my site i am getting this error page:

 

Limit Exceeded

Sorry for the inconvenience. Please email us if you need to get in touch.

 

Can anyone please tell why it is happening?

Using the new "My Domain "  feature in spring 10 can we solve the javascript cross domain issues? 

 

As per the documentation 

Personalize your salesforce.com URL  - Get a personalized, easy-to-remember saleforce.com URL Provide additional security to your organization.

 

Q: Will the apex code also run on the same domain (which otherwise runs in the force.com domain) there by solving the cross domain javascript issues faced now within an iframe.

 

Thanks

Sree

 

Hello SF,

 

I am new to building SF Sites and have a few questions on design. I currently have a basic two-column design (header, left menu, body, footer). I am using components to populate the header, footer, and menu so I don't have to re-write the code for each page etc. Rather than creating separate pages, I would like to use components to populate the body as well, which will usually be a form.

 

My question: Using the left menu html links, what is the best way to populate data in the body of the page? I want a user to click a left-nav link and then have the body of the page populate with the correct component (i.e. form) info etc. I have looked everywhere and am unable to locate info on this use-case. I found brief examples of Ajax using "rerender" but I can not figure out how to integrate this with my setup (i.e. which code goes where).

 

My logic/concept may be completely wrong so suggestions, example code, or links to tutorials are much appreciated.

 

 

Hello -

I am having difficulty getting my links between VF pages on my Sites to work correctly, can someone please take a look

and let me know what I am doing wrong. All my VF pages are associated to my site and public, I have a link to a "Locations" page and of course my "Home" link.

Any help is appreciated.

 

Thanks

Amanda

 

<apex:page showHeader="false" standardStylesheets="false" cache="true" expires="10800"> 
<html>
<head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8"></meta>
    <title>PPM Technologies</title>
    <apex:stylesheet value="{!$Resource.atest1}"/>
</head>
 
<body>
<div>
    <div><apex:image url="{!$Resource.topborder1}"></apex:image></div>
 
            <div>
            <ul>
            <li><a href="https://na5salesforce.com/apex/ahhomepage">Home</a></li>
            <li><a href="https://na5salesforce.com/apex/ahwebpage2">Locations</a></li>
            </ul> 
            </div>
 

 

Hi all,

 

I want to embed partner portal login page into my visualforce page.

Can anyone please let me know how to do this?

 

This is my first attempt at creating a sites page.
I'm unable to get any non-required field to display on the public site. The required fields display ok. By 'required', I mean required as set in the custom object.
 
Here is the visualforce page code...
 
<apex:page showHeader="false" sidebar="false" standardController="Complaint__c">
    <h1>Online Complaint Handling</h1>
    <apex:form >
        <apex:outputText value="Are you logging the complaint for yourself?" />
        <apex:inputField value="{!Complaint__c.Logging_this_complaint_for_yourself__c}" />
        <br/>
         
        <apex:outputText value="Complainant First Name" />
        <apex:inputField value="{!Complaint__c.Complaint_First_Name__c}" />
        <br/>
        
        <apex:outputText value="Relationship to Caller" />
        <apex:inputField value="{!Complaint__c.Relationship_to_Caller__c}" />
        <br/>
         
        <apex:outputText value="Caller Name" />
        <apex:inputField value="{!Complaint__c.Caller_Name__c}" />
        <br/>
         
        <apex:outputText value="Caller State" />
        <apex:inputField value="{!Complaint__c.Caller_State__c}" />
        <br/>
        
        <apex:outputText value="Date of Call" />
        <apex:inputField value="{!Complaint__c.Date_of_Call__c}" />
        <br/>
        
    </apex:form>
</apex:page>
 
 
Only the Caller_Name__c and the Date_of_Call__c input fields display on the public site, and they are the only 'required' fields from the Complaint custom object. The other input fields such as Complaint_First_Name__c just don't display on the public site.
 
The page displays correctly if previewed from within Salesforce via https://ap1.salesforce.com/apex/Complaint for example.
 
Can anyone offer some help as to what is wrong?
 

Hi,

 

I got a developer edition account of Salesforce before. Now, I want to enable my environment to Chatter-enabled. But I don't know how to do it. I find an answer on Salesforce online help like this:

 

"Enable Salesforce Chatter to turn on feeds and profiles so people in your organization can collaborate with each other in real time.

  1. Click Setup | Customize | Chatter | Settings.
  2. Click Edit.
  3. Select Enable.
  4. Optionally select Allow Emails so users can choose to receive email notifications about Salesforce Chatter activities.
  5. Click Save."

Something strange, I can't find the 'Chatter' tab after expanding the 'Customize' tab at all. How the hell can i turn on the Chatter-enabled environment?

 

Regards

 

 

    I have a list of our office IP Ranges. Entered them into the appropriate area for our site's profile. But then we got totally locked out of the site. So my first question is does anybody know about anything funky when enabling Login IP Ranges? I removed the IP Ranges but the site is still unaccesible, getting authorization required message. Its been at least 15 minutes since i removed the IP ranges but the site is still locked out. 

     

    Does anybody have insight on whats going on? Just to verify the site did work just fine before, it had been up for a few days and everybody could see it. We wanted it to be internal so I got a list of our external IP's. Even went to whatsmyip.com to verify. 

    I have a component I use on a VF page in a Site with a prefix--http://mysite.force.com/events. I create a relative link to a VF page that is part of the site like this:

     

     

    <a href="Event?id={!event.Id}">{!event.Name}</a>

     

     

    The link the component creates drops the prefix, however, and looks like this: http://mysite.force.com/Event?id=00dhwhegdhewy

     

    What's the best way to preserve the site prefix in this case without hard-coding it into the component?

     

    Thanks,

    Steve

    Hi, I'm new to the board and to Salesforce.  I started building some Visualforce pages controlled by a custom controller, and I'm not able to get the Page Editor working.  I need it for debugging since I'm still really unsure of the syntax.  I did some searching through the discussion board and didn't find anything pertaining to my problem.

     

    I have Development Mode turned on for my user settings, and I've also set my URL to apex:

    https://mydomain.xxx.cs3.force.com/apex/my_page

     

    I realized that I should be seeing a split screen and/or a Page Editor button at the bottom of the screen, but I see neither.  I tried it in Firefox and Chrome in both Windows and Linux.  

     

    I have a feeling it's a security issue because I get a Authorization Required  login page when I know there is an error with the page.  What am I doing wrong here?  Please help!  I'm out of ideas on this.  Thanks in advance.

    • May 24, 2010
    • Like
    • 0

    Hello -

    Trying to create a very simple public website for my customer, I don't want them to have access

    to any Salesforce content as of yet, this will simply be a temporary webpage with some

    business content. Anyway - I read in the Help & Training area that creating a "Static Resource"

    to house my CSS & Html code, maybe logo images and such was better then creating links

    back to the documents tab. Can anyone tell me if this is true?  If I can upload a zip file with all

    my pertinent codes, images, etc....and then simply reference that zip file in my apex visual force page?

    I want my website to look just like a normal website, no salesforce formatting/feel.

    If this is possible what is the code/reference I would use on my visualforce page.

     

    Thanks in advance

    Amanda

    Hello -

    I'm just getting started trying to create a very basic public website for my customers.

    I have EE and know this is possible. After I created my site I need to assign my visual force

    home page. Can I simply copy and paste already existing HTML page into a visual force

    page without having to use excessive amounts of apex coding?

     

    Any help or comments appreciated.

     

    Amanda

             Earlier I came across a feature that allowed me to view Salesforce.com setup as a certain type of user without having to re-login.  I think it simply required selecting the user (or Role?) from a drop down list. 

     

           Now I cannot find this feature. I have tried searching Salesforce.com, Force.com, the developer edition, Google, etc. without luck.  Can anyone tell me how to find this feature? 

     

           Thanks in advance for your help.

    Hi,

    When I logged in as Admin, I am not able to search community / portal users in Chatter -> People tab. I am not able to add those users to groups. 

    On the other hand, when I logged in as portal user, I am able to view internal users as well as portal users in Chatter -> people.

    Can someone please help..?

     

    We've been finding that, intermittently, the Site.createPersonAccountPortalUser(userObj, newUserOwnerId, recordTypeId, password) method is retuning a null value, instead of a valid Id for a new User record. No exception is thrown; just a null value is returned.

     

    When this happens we look at the org and find that a User record WAS inserted, as well as *multiple* Account records.

     

    We have been unable to reproduce this using identical input data. 

     

    Has anyone else seen this behavior? 

    Hey guys,

     

    I'm in the middle of experimenting with and testing with a site to get used to force.com, but the more I work with this, the more I wonder if it's possible use this site for a actual company site that I'll soon be using force.com to make. Is there a means to transfer the data well? I'd appreciate information or a link with answers.

     

    Thanks in advanced.

    • October 05, 2010
    • Like
    • 0

    I'm trying to use getContent() on the Force.com sites to pull some files with data in from a static resource.

     

    I've been able to do it successfully with a normal Salesforce app, but in Sites I can't seem to get any data. It puts me straight onto a maintenance page with no error messages or debug logs (as I'm only a guest).

     

    Does anyone have any ideas?

    Hi,  thanks for reading...

     

    I'm having trouble finding where some of my code is going wrong.

     

    The code is uploaded from the IDE just fine but when executed via a command button:

     

     

     

    apex:commandButton action="{!shop}" value="Buy"

     

     The code leads to a "is down for maintenance ".

     

    When I was an undergrad writing code; I used to be able to write to stdout... to see how far my code was going before it went awry...

     

    Is there a way to do this in Apex for visualforce pages?

     

    Thanks,

     

    Eric

    I have created a Visualforce Page from Develop/Pages with Salesforce. When I reference this from within Salesforce using /apex/pagename it is displayed. When I reference this page from within our website, I am getting the page does not exist down for maintenance.

     

    I have taken a clone of an existing page and I thought it woudl work fine as the orginal works ok, the ony difference I can see is that the security on the orginal file has 2 profiles and the clone only has one. I cannot find the other profile to add to the clone page. Do you need to assign profiles to pages under Security to make them visible or Have I missed out a step when trying to publish this page.

     

    Your help would be appreciated.

     

    Kind regards

     

    Brian

    I want the login_portal.jsp to be displayed on an html page.  I have used an iframe.  But, when a valid login occurs, I am still stuck in the iframe embedded on an html page.  I there another way to embed this log in and get to the correct landing page and be in another tab/page of the browser?  All help appreciated.

     

    • September 28, 2010
    • Like
    • 0

    Developer Site at SFDC

    Google Apps

     

    1. Do I have an SFDC Domain, where would I look if I do?

    2a. Can I add Google Apps when I don't have a domain?

    2b. If so, how?

     

    TIA

     

    JeffP...

    • September 28, 2010
    • Like
    • 0

    I have a single Contact enabled as a Contact Portal user, and created a login and password for that Contact.  Logging in as that user results in an error on my custom page (apparently): "Error: Error occurred while loading a Visualforce page."  No email was generated for the Administrator, though.

     

    Is there a way to create a Debug Log for the Contact Portal user?  How can I identify what the VF error is, otherwise?

    I am working in my dev org to allow access to a custom visualforce page through Sites.  The page displays a single Account and some related Custom Objects, and i made these accessible to the Guest User profile.  I was seeing the page but without details (though the Custom Controller is hard-coded to display a particular Account), so I decided to see what I could gain access to through using the Customer Portal.  The Customer Portal has access to even fewer objects than the Guest User (no custom objects at all), so that was a wrong move, but now although I deselected Login Enabled so that on the Sites detail page is reads 'Login - Not Allowed', the Guest User has no access at all - I get the 'Authorization Required' page.

     

    I tried deactivating the Site and creating a new one, but my Dev Org only has one Sites license, even if the other is disabled.  And there is no way (that I can see) to delete the Site and start over.

     

    So it appears that I am stuck with the Customer Portal: Contact Portal login.  I'm getting an error there as well, and no email is being generated telling me (in my Admin role) what the issue is.

     

    Is there a way, through Eclipse perhaps, to delete the Site from Dev Org so that I can try again?

     

     

    How to create groups in chatter.

    Can we assign users to hav access to only particular chatter group.

     

    Hi,

     

    We currently have web to case enabled so clients can send us support request.

     

    Had an idea to create a visualforce page within the clients org with the web to lead HTML generated code so the client can send tickets right from there system.

     

    Problem is nothing happens, is this not possible I thought VF support HTML and Java.

     

    Thanks

     

    Ross

    I have two questions that should be pretty simple although I have spent good time trying to find the solution.

     

    First: On my site I have a component acting as my sidebar with a set of links. When one of the links is clicked, I want it to dynamically set the record type. For example, if the user clicks the enrollment link, it would take them to the enrollment page, but I also want the record type to be set to "enrollment". Via the UI you can set record type via the URL but I do not know how to accomplish this via Sites.

     

    <apex:component >
      <div id = "menu_container">
        <div id = "menu">
          <ul>
            <li class="menu_header">Some Name
              <ul>
                <li><a href="http://testing.somename.cs3.force.com/enroll">Enrollment</a></li>
                <li><a href="http://testing.somename.cs3.force.com/cert">Certification</a></li>
              </ul>
            </li>                            
          </ul>
        </div>
      </div>
    </apex:component>

     

    Second: I'm sure there is a better way of linking to pages vs. the static example above. I want to avoid scanning through the site if I change the name of a Page. Is there a better way of referencing a Page via a link?

     

    Any assistance with code, ideas, and/or examples is much appreciated.

    • September 24, 2010
    • Like
    • 0

    Is there any way to force a site wide Akamai refresh?

    • September 23, 2010
    • Like
    • 0

    Simple question really but one that's difficult to test without messing with production systems! We have several Sites that use urls like www.mydomain1.com, www.mydomain2.com style but now need one that uses nonewww.mydomain3.com to sit alongside www.mydomain3.com (not served by force.com). Is this possible?

    When someone inside my company (with a System Admin login into Salesforce) creates a new Site, they want to be able to pre-create a few throusand new Sites logins, based on CampaignMember data, and then send email messages out to those people, giving them their login information. They don't want the Campaign Members to have to self-register for a Sites login. Is there some way I can write Apex code (maybe in a Visualforce controller, or maybe in a batch Apex process) that finds all the relevant Campaign Members and then creates Sites logins for them?

     

    Thanks!

    Hi All,
    I have created a salesforce web site successfully but i am not able to show the values which are in organization object.
    In VF page its working fine but the same code in site page is not working......can any one suggest me the best way
    to display the object record details on the site.

    code goes here

    page
    -------
    <apex:page showHeader="false" controller="pdftets" >
    <script>
    function fun(a)
    {
    var s=new String(a);
    // alert(s);
    window.open(s);
    }
    //window.parent.location.href =s;}

    </script>
    <apex:form >
    <apex:composition template="{!$Site.Template}">
    <apex:define name="body">
    <table style="width: 181px">
      <tr>
        <td>   
        <apex:dataTable value="{!accounts}" var="account" id="theTable" width="100%" columns="3">
            <apex:facet name="header">Real Estate News</apex:facet>               
                    <apex:column width="60%">

     


                     <apex:facet name="header">Article</apex:facet>
                        <a href="#" onclick="fun('{!account.Document_URL__c}')" >{!account.name}</a>
                    </apex:column>
                    <apex:column width="10%">
                            <apex:facet name="header">Source</apex:facet>
                              {!account.Source__c}
                    </apex:column>                
                     <apex:column width="20%" >
                       <apex:facet name="header">Date </apex:facet>
                    <apex:outputText value="{!account.CreatedDate}"/>
                    </apex:column>
            </apex:dataTable>
        </td>
      </tr>
    </table>

    </apex:define>
    </apex:composition>
    </apex:form>       
    </apex:page>

    controller
    --------------
    public with sharing class pdftets {
      List<News_and_Events__c> NewsandEvents1;
            public List<News_and_Events__c> getAccounts() {
           NewsandEvents1= [select name,Source__c,CreatedDate,Document_URL__c from News_and_Events__c limit 10];

                    return NewsandEvents1;
            }
     public string Rctype{get;set;}

    }

    Hello,

     

    I have the free developer edition but in order to develope apex code I need to use a sandbox,

    (don't have on setup->develope->apex the button "new" for adding new apex code).

     

    I was wondering, is that normal? do I need a "developer edition organization" in order to code in apex without a sandbox?

    or is actually "Free Developer Edition" == "Developer Edition Organization" and apex coding is always done on a sandbox?

     

    Thanks,

    Guy